axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaushalye Kapuruge <kausha...@wso2.com>
Subject Re: HTTP headers
Date Wed, 11 Jul 2007 16:13:24 GMT


Stefano Pettini wrote:
> Thank you Sahan, so AXIS2C-639 can be closed. Can I suggest to change 
> name of "internal" constants AXIS_SOAP_11 and _12 in axis2_options.h 
> and axis2_stub.h to less misleading names?

+1. Seems we don't use 'em anywhere. Do we?
And the axis2/C manual suggests that we have to use these constants, 
which is wrong... :(
http://ws.apache.org/axis2/c/docs/axis2c_manual.html
Cheers,
Kaushalye
> Cheers,
> Stefano
>
> Sahan Gamage wrote:
>> Hi Stefano,
>>
>> See my comments below ..
>>
>> On 7/11/07, Stefano Pettini <spettini@users.sourceforge.net> wrote:
>>> Hi Kaushalye,
>>>
>>> probably the issue I'm talking about is different than AXIS2C-124. I
>>> tested again the soap client and here are the results:
>>>
>>> With:
>>>
>>> No axis2_options_set_soap_version call or
>>> axis2_options_set_soap_version(axOptions, axEnv, AXIOM_SOAP_11)
>> The correct constant to set soap version 1.1 is AXIOM_SOAP11. Please
>> have a look at axiom_soap_const.h.
>>>
>>> I get:
>>>
>>> content-type: application/soap+xml;charset=UTF-8;action="helloAction";
>>>
>>> With:
>>>
>>>
>>> axis2_options_set_soap_version(axOptions, axEnv, AXIOM_SOAP_12)
>> Again correct constant is AXIOM_SOAP12.
>>
>>
>> Thanks
>> -sahan
>>>
>>>
>>> I get:
>>>
>>> content-type: text/xml;charset=UTF-8
>>> soapaction: "helloAction"
>>>
>>> No special option is written in axis2.xml.
>>> MTOM and REST default options have been commented out from axis2.xml.
>>>
>>> I raised this issue in JIRA (AXIS2C-639).
>>>
>>> BTW, I'm not sure the trailing ; at the end of first content-type is
>>> correct or should be removed
>>>
>>> Cheers,
>>> Stefano
>>>
>>> Kaushalye Kapuruge wrote:
>>> > To add to my previous mail,
>>> > We had this issue some time back and it's fixed from Axis2/C version
>>> > 0.91. (See JIRA[1]).
>>> > If you see this again please raise the issue in JIRA. But I tried 
>>> this
>>> > with Axis2/C 1.0 and works fine for me.
>>> > Cheers,
>>> > Kaushalye
>>> > [1] http://issues.apache.org/jira/browse/AXIS2C-124
>>> >
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message