axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kaushalye Kapuruge <kausha...@wso2.com>
Subject Re: HTTP headers
Date Tue, 10 Jul 2007 17:37:35 GMT
To add to my previous mail,
We had this issue some time back and it's fixed from Axis2/C version 
0.91. (See JIRA[1]).
If you see this again please raise the issue in JIRA. But I tried this 
with Axis2/C 1.0 and works fine for me.
Cheers,
Kaushalye
[1] http://issues.apache.org/jira/browse/AXIS2C-124

Kaushalye Kapuruge wrote:
> Stefano Pettini wrote:
>> Hi all again,
>>
>> multithreading issue is still open, but now I'm looking at http 
>> headers sent by the client. If I don't specify a SOAP version, the 
>> clients sends content-type: 
>> application/soap+xml;charset=UTF-8;action=helloAction, while if I set 
>> SOAP version 1.2, using axis2_options_set_soap_version(axOptions, 
>> axEnv, AXIOM_SOAP_12), the client sends content-type: 
>> text/xml;charset=UTF-8 and a separate soapaction.
>>
>> Do you confirm this behavior is intended and standard?
> Nop. If the SOAP version is 1.2, then there is NO sperate SOAP action. 
> Instead you should see something like follows in your headers.
> ...charset="UTF-8";action="http://xmlsoap.org/your/action"Host: 
> your.host...
> Cheers,
> Kaushalye
>>
>> Thanks.
>> Stefano
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message