axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dr. Florian Steinborn" <fpu...@gmx.de>
Subject Re: [AXIS2C] codegen - SOAPAction
Date Sat, 23 Jun 2007 20:41:57 GMT
Hi Mark,

> otherwise, when my java-client sends the request with the
> SOAPAction="foo" in the header, the c-server could not
> find the method and replies with the fault :
> "Operation Not Found"
> [i think this was my problem in the mail from 21.6.2007]

And this is exactly what I reported here on June 20th (codegen problem).

>
> at the c-server side in the method "axis2_svc_skel_<servicename>_invoke"
>
> i implemented the buissness-logic as following :
>
> if (axutil_strcmp(op_name, "foo") == 0)
> {
>      ret_val2 = axis2_skel_<servicename>_foo(env);
>      ret_node = axis2_DeviceInfo_serialize(ret_val2, env, NULL, 0);
>      return ret_node;
> }

And this is probably what Milinda suggested...


>
> with a breakpoint in the invoke method i found out, that the server
> didn't reach this method, when calling with the java-client, but the
> java-client sends the SOAPAction="foo".
>
> otherwise when i set up a request with SOAPUI 1.7.1 and
> send the methodname "foo" as first element in the soap-body,
> the c-server response is fine (the breakpoint was reached).
>
> so what do i have to do, to set the SOAPAction accurately ?

I am sorry - I do not know... I am still thinking about the exception  
thing from yesterday.... (and can't find a solution...)

Flori

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message