axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aljaznoe <aljaz....@halcom.si>
Subject AXIS-C++ on IBM AIX
Date Wed, 09 May 2007 11:12:28 GMT

Hi!

I would like to use AXIS-C++ on IBM AIX 5.2.  I've tried the binary version
available from
http://www.apache.org/dist/ws/axis-c/binaries/aix/axis-c-1.6b-AIX-trace-bin.tar.gz,
but there seem to be some linking issues xerces library.

Specifically,

I generated created calculator client example in c++ from calculator.wsdl.
I've set the configuration files, paths, libpath's... everything.
The code compiles (and links - statically) OK with xlC compiler.
When I run the example, I get the following error in AxisClientLog, which is
followed by a segfault.



[09/05/2007 12:30:01:709 DFT] 1 - I -------------- Config File settings
START ----------------
[09/05/2007 12:30:01:709 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000000] <....>
[09/05/2007 12:30:01:709 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@1 <null>
[09/05/2007 12:30:01:709 DFT] 1 - I AXCONF_WSDDFILEPATH = NULL
[09/05/2007 12:30:01:709 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000001] <....>
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "/usr/local/axiscpp_deploy/log/AxisLog"
[09/05/2007 12:30:01:710 DFT] 1 - I AXCONF_LOGPATH =
/usr/local/axiscpp_deploy/log/AxisLog
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000002] <....>
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "/home/ccuser/ane/inst/axis-c/depcli/log/AxisClientLog"
[09/05/2007 12:30:01:710 DFT] 1 - I AXCONF_CLIENTLOGPATH =
/home/ccuser/ane/inst/axis-c/depcli/log/AxisClientLog
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000003] <....>
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@1 <null>
[09/05/2007 12:30:01:710 DFT] 1 - I AXCONF_CLIENTWSDDFILEPATH = NULL
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000004] <....>
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "/home/ccuser/ane/inst/axis-c/depcli"
[09/05/2007 12:30:01:710 DFT] 1 - I AXCONF_AXISHOME =
/home/ccuser/ane/inst/axis-c/depcli
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000005] <....>
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "libhttp_transport.so"
[09/05/2007 12:30:01:710 DFT] 1 - I AXCONF_TRANSPORTHTTP =
libhttp_transport.so
[09/05/2007 12:30:01:710 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000006] <....>
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@1 <null>
[09/05/2007 12:30:01:711 DFT] 1 - I AXCONF_TRANSPORTSMTP = NULL
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000007] <....>
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "libaxis_xerces.so"
[09/05/2007 12:30:01:711 DFT] 1 - I AXCONF_XMLPARSER = libaxis_xerces.so
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000008] <....>
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "server name"
[09/05/2007 12:30:01:711 DFT] 1 - I AXCONF_NODENAME = server name
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000009] <....>
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "listen port"
[09/05/2007 12:30:01:711 DFT] 1 - I AXCONF_LISTENPORT = listen port
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[0000000A] <....>
[09/05/2007 12:30:01:711 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "Unknown"
[09/05/2007 12:30:01:711 DFT] 1 - I AXCONF_SSLCHANNEL_HTTP = Unknown
[09/05/2007 12:30:01:712 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[0000000B] <....>
[09/05/2007 12:30:01:712 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "libhttp_channel.so"
[09/05/2007 12:30:01:712 DFT] 1 - I AXCONF_CHANNEL_HTTP = libhttp_channel.so
[09/05/2007 12:30:01:712 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[0000000C] <....>
[09/05/2007 12:30:01:712 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@1 <null>
[09/05/2007 12:30:01:712 DFT] 1 - I AXCONF_SECUREINFO = NULL
[09/05/2007 12:30:01:712 DFT] 1 - I -------------- Config File settings END
OF ----------------
[09/05/2007 12:30:01:712 DFT] 1 XMLParserFactory > initialize 
[09/05/2007 12:30:01:712 DFT] 1 AxisConfig > getAxisConfProperty
@2000bd28,[00000007] <....>
[09/05/2007 12:30:01:712 DFT] 1 AxisConfig < getAxisConfProperty
@2000bd28,@2 "libaxis_xerces.so"
[09/05/2007 12:30:01:712 DFT] 1 XMLParserFactory > loadLib 
[09/05/2007 12:30:01:741 DFT] 1 AxisEngineException > AxisEngineException
@2ff21f68,------------>
[09/05/2007 12:30:01:741 DFT] 1 - I 29, "Failed to load parser within server
engine: 
[09/05/2007 12:30:01:741 DFT] 1 - I                  Error Message='Exec
format error'                Error Code='8'
[09/05/2007 12:30:01:741 DFT] 1 - I                  Load lib error='
0509-130 Symbol resolution failed for
/home/ccuser/ane/inst/axis-c/lib/axis/libaxis_xerces.so because:
[09/05/2007 12:30:01:741 DFT] 1 - I 	0509-136   Symbol
fgXercescDefaultLocale__Q2_11xercesc_2_26XMLUni (number 28) is not exported
from
[09/05/2007 12:30:01:741 DFT] 1 - I 		   dependent module
/usr/local/xerces-c-aix_510-xlc_60_050623/lib/libxerces-c.a.
[09/05/2007 12:30:01:741 DFT] 1 - I 	0509-136   Symbol
__dt__Q2_11xercesc_2_211InputSourceFv (number 29) is not exported from
[09/05/2007 12:30:01:741 DFT] 1 - I 		   dependent module
/usr/local/xerces-c-aix_510-xlc_60_050623/lib/libxerces-c.a.
[09/05/2007 12:30:01:741 DFT] 1 - I 	0509-136   Symbol
setEncoding__Q2_11xercesc_2_211InputSourceFPCUs (number 30) is not exported
from
[09/05/2007 12:30:01:741 DFT] 1 - I 		   dependent module
/usr/local/xerces-c-aix_510-xlc_60_050623/lib/libxerces-c.a.
[09/05/2007 12:30:01:741 DFT] 1 - I 	0509-136   Symbol
setPublicId__Q2_11xercesc_2_211InputSourceFPCUs (number 31) is not exported
from
[09/05/2007 12:30:01:741 DFT] 1 - I 		   dependent module
/usr/local/xerces-c-aix_510-xlc_60_050623/lib/libxerces-c.a.
[09/05/2007 12:30:01:742 DFT] 1 - I 	0509-136   Symbol
setSystemId__Q2_11xercesc_2_211InputSourceFPCUs (number 32) is nńMÚ(ÝZßĐ"
[09/05/2007 12:30:01:742 DFT] 1 AxisEngineException >
getMessageForExceptionCode @2ff21f68,29
[09/05/2007 12:30:01:742 DFT] 1 AxisEngineException <
getMessageForExceptionCode @2ff21f68,"DLOPEN FAILED in loading parser
library"
[09/05/2007 12:30:01:742 DFT] 1 AxisEngineException >
getMessageForExceptionCode @2ff21f68,29
[09/05/2007 12:30:01:742 DFT] 1 AxisEngineException <
getMessageForExceptionCode @2ff21f68,"DLOPEN FAILED in loading parser
library"
[09/05/2007 12:30:01:742 DFT] 1 AxisEngineException < AxisEngineException
@2ff21f68



It looks like the xerces library does not provide some required symbols. The
above log was produced when using xerces 2.7.0. Same error, but with
different symbols is produced when using xerces 2.2.0 (from 
http://archive.apache.org/dist/xml/xerces-c/Xerces-C_2_2_0/xerces-c2_2_0-AIX51_5.02.tar.gz).


Questions:

Has anyone been able to use axis-c on AIX? What version of axis-c (and
dependent libraries) work best? Are there binaries available? If not, what
is the correct build procedure?

I know the above calculator client example is the most basic thing to do
(haven't tried the server yet). Are there any other known issues with axis-c
and AIX related to more advanced things (server, apache mod...)


Thanks for your help,

Aljaz

-- 
View this message in context: http://www.nabble.com/AXIS-C%2B%2B-on-IBM-AIX-tf3715116.html#a10392346
Sent from the Axis - C++ - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message