axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jose angel garcia" <jagarcia.po...@gmail.com>
Subject Re: Problems with Creation and Destruction of client Stub
Date Wed, 18 Apr 2007 08:31:19 GMT
Hi, thanks for the fast answer;
yesterday i reduced the aplication to a two calls service, and a dialog
client.
An even stranger thing happended as it didn't send authentication
information in the http header, although i used the same code and setup that
in the previous aplication (that sended it). Any way, the previous problem
still,  and i noticed that the client start sending the header message for
the second call but miss the body.

I post the the piece of message send captured with tcpmon(nitor), the wsdl
file, the tracelog, the generated src, and code initialization (ws stub
instantiated on var *m_pWS).

Finally I also would like to ask for experiences using an Axis2 client
against Axis1 server.

Thanks
José Ángel García

2007/4/17, Nadir Amra <amra@us.ibm.com>:
>
> Jose,
>
> If you can recreate using as simple a Web service as possible, and attach
> generated code with WSDL and  with SOAP responses, I can take a look.
>
> Nadir K. Amra
>
>
> "jose angel garcia" <jagarcia.polar@gmail.com> wrote on 04/16/2007
> 12:21:11 PM:
>
> > Hi all!
> > Spanish guy with probs in despair (well not actually, but about to
> > lost sanity ;)
> >
> > I am intercomunicating a c++ desktop client (dev. in MSV6.0 with
> > Axis-cpp) to a Axis Java Server (running in Tomcat) for 2 months.
> > Now that everything it is setup I am stuck becouse of some issues I
> > would like to comment, for someone to put me on the right way.
> >
> > The problems seems enterrily affect the client side. Tested from a
> > java client the service works ok.
> >
> > The cpp client is using Axis-C Nightly build binaries with Xerces 2.6
> lib.
> > First problem is on the second call to the web service done after
> > son user interaction.
> > It's seems to works ok on the traces, but no message is send. So the
> > client enter in
> > the parser timeouts waiting for the response hearder, until finally
> crashing.
> > The strange things is that if the two calls are invoked secuentially
> > no problems arise.
> >
> > To overpass this, I try to use a new stub whenever user interactions
> > were to be done
> > between service calls. But when I delete the service stub another
> > crash happens. So
> > I'm stuck now.  Any ideas?
> >
> > Thx in advance
> > José Ángel García
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-c-user-help@ws.apache.org
>
>

Mime
View raw message