axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Porter <stev...@trigent.com>
Subject Cannot load mod_axis2.dll into server. The specified module could not be found.
Date Tue, 20 Mar 2007 13:47:33 GMT
Hello,

 

I am very new to both Web Services and Axis.  I installed Axis 1.6 (the
build from Aug-06), along with Apache 2.2.  I followed all the instructions
to create and deploy my web service.  However, when I try to start the HTTP
server, the first error I kept getting was

 

 "httpd: Syntax error on line 487 of C:/Program Files/Apache Software
Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files/Apache
Software Foundation/Apache2.2/modules/mod_axis2.dll into server: The
specified module could not be found."  

 

At some point I determined that the mod_axis2.dll file probably was being
found, but it could not find the msvcp70.dll and msvcr70.dll (which are not
included in the install kit).  After finding those online someplace, I got
the same error, but determined that the missing dll was probably libapr.dll.
The Apache2.2 installation includes a libapr-1.dll.  So taking a simplistic
approach, I copied libapr-1.dll to libapr.dll.  Now I get 

 

"httpd: Syntax error on line 487 of C:/Program Files/Apache Software
Foundation/Apache2.2/conf/httpd.conf: API module structure 'axis_module' in
file  C:/Program Files/Apache Software
Foundation/Apache2.2/modules/mod_axis2.dll is garbled - perhaps this is not
an Apache module DSO?"  

 

So at this point I am sure I am doing many things wrong, could somebody tell
me what they are?

 

Thanks, Steve

 

 

 

Steve Porter

Trigent Software Inc.

One Apple Hill, Suite 204

Natick, MA 01760

508-651-5958

781-929-7567 (cell)

www.trigent.com

 


Mime
View raw message