axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iwan Tomlow" <iwan.tom...@seagha.com>
Subject Invalid byte 2 of 2-byte UTF-8 sequence?
Date Wed, 28 Mar 2007 11:22:00 GMT
Hi,

when connecting an Axis-C client (v1.5) to an Axis-java webservice, the return message has
the following error:

<soapenv:Fault>
  <faultcode>soapenv:Server.userException</faultcode>
   <faultstring>java.io.UTFDataFormatException: Invalid byte 2 of 2-byte UTF-8 sequence.</faultstring>

The only difference with all other working requests, seems the company name containing "G√úTER".
When debugging, the U-umlaut is showing correctly everywhere, but apparently the receiving
webservice isn't getting it correctly.
The source message generated by Axis-C++ looks like this in TCPMonitor:

Content-Type: text/xml; charset=UTF-8

<?xml version='1.0' encoding='utf-8' ?>
...
                  <ns1:company>ROTTMANN HEINRICH G TER</ns1:company>

So it seems the character is indeed being encoded incorrectly by Axis-C?


Does anyone have any hints to get this working?

By the way, I receive this company-name via another webservice, and I notice that they sent
me this:

<employerName>ROTTMANN HEINRICH G&#xDC;TER</employerName>

Maybe there is a way to configure Axis-C to do the same, sending a character reference to
avoid the encoding-mismatch?

Kind regards,
Iwan Tomlow

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message