axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bradley Beddoes <bedd...@intient.com>
Subject [Axis2C] Creating an SSL client - trunk
Date Thu, 22 Feb 2007 10:09:10 GMT
Hi,
I have been playing with a trunk build the past few days and have 
managed to get everything working quite nicely with http connections.

However with https connections I can't seem to make my client perform an 
operation. I have followed the SSL client instructions online exactly 
and they did not help at all. The correct transport is enabled in axis2.xml

So far I have been getting the following output from my client logging 
(from axis2_env_t structure) "Stub invoke FAILED: Error code: 82 :: 
Input stream is NULL in msg_ctx". Additionally for completeness the echo 
sample also described online has the exact same output when attempting 
to execute it.

Following the code through I believe that the environment variable 
described in the online document is not even consulted, looking at 
things further I am now attempting to set the following in my client:
AXIS2_OPTIONS_SET_PROPERTY(options, env, "SERVER_CERT", 
"/path/to/my/cert.pem");

This is currently causing me a segfault which I am still investigating. 
While I continue looking at this can anyone shed some light on why this 
might be occurring and what to do to fix?

Bradley

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message