axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ritu gaud <urvashi_g...@yahoo.co.in>
Subject Re: [Axis2]VC2005 Build problem (was Re: hello)
Date Wed, 24 Jan 2007 09:22:00 GMT
hi nandika,
   
  thanks a lot. i got .exe by ur help.
   
  thanks,
   
  bye. 

Nandika Jayawardana <jayawark@gmail.com> wrote:
  hi ritu,

you need to have following .lib files in your LIB path to avoid there errors,
The libraries are 
   axis2_util.lib  axis2_engine.lib axiom.lib axis2_parser.lib

you will find these libraries in <axis2 binary directory>\lib directory. 

If you are building using a vc project , add these to properties->linker->input->Additional
Dependencies.

regards
Nandika


  On 1/24/07, ritu gaud <urvashi_gaud@yahoo.co.in> wrote:    hello,
   
  these r the linking errors
   
  error LNK2019: unresolved external symbol __imp__axis2_log_impl_log_error referenced in
function _wmain 
   
  math.obj : error LNK2019: unresolved external symbol __imp__axis2_svc_client_create@8 referenced
in function _wmain
   
  math.obj : error LNK2019: unresolved external symbol __imp__axis2_options_create@4 referenced
in function _wmain
   
  math.obj : error LNK2019: unresolved external symbol __imp__axis2_endpoint_ref_create@8
referenced in function _wmain
   
  math.obj : error LNK2019: unresolved external symbol __imp__axis2_strcmp@8 referenced in
function _wmain
   
  math.obj : error LNK2019: unresolved external symbol __imp__axis2_env_create_all@8 referenced
in function _wmain 
   
   
  math.obj : error LNK2019: unresolved external symbol __imp__axiom_namespace_create@12 referenced
in function "struct axiom_node * __cdecl build_om_payload_for_echo_svc(struct axis2_env const
*)" (? build_om_payload_for_echo_svc@@YAPAUaxiom_node@@PBUaxis2_env@@@Z )
   
  
Nandika Jayawardana < jayawark@gmail.com> wrote:   Hi ritu,

can you send the link error messages,

Thanks
Nandika

  On 1/24/07, Dinesh Premalal < xydinesh@gmail.com > wrote:   Hi Urvashi,

ritu gaud < urvashi_gaud@yahoo.co.in> writes:


> i downloaded the VC2005 Express Edition and set all the library and home path
> correctly, still i hv a problem while linking, same errors are persisting.
> is there any other settings also?
> which source file u compiled and linkd to generate .exe, i tried both echo.c
> and math.c, hv u made any changes to code?
These days there is performance tuning changes in 
progress. Therefore  there may be major changes to code base but we
always make sure to keep a stable build. I think linking problem
occur not because changes in code base but some other reason. I'm
afraid , I'm not familiar with VC to suggest a solution. Be patient :) 


thanks,
Dinesh

ps: please make sure to have [Axis2] prefix for axis2c related threads :)

--
Dinesh Premalal
dinesh@wso2.com 
WSO2, Inc.; http://www.wso2.com/
GPG Key ID : A255955C
GPG Key Finger Print : C481 E5D4 C27E DC34 9257  0229 4F44 266E A255 955C 

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org 





  
  
---------------------------------
  Here's a new way to find what you're looking for - Yahoo! Answers   




 				
---------------------------------
 Here’s a new way to find what you're looking for - Yahoo! Answers 
Mime
View raw message