axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clifford Audinet <clifford.audi...@stonebranch.com>
Subject [Axis2] axis2_svc_client_create_for_dynamic_invocation returns NULL
Date Thu, 25 Jan 2007 12:35:24 GMT
Hello,

I am attempting to use the dynamic_client example bundled with axis2c
and have encountered a problem I hope you can shed some light on.  But
first the particulars.

I am using:
axis2c v0.96 win binaries
WinXP Pro as the dev platform
MS Visual C++ 6.0

The Installation:
I didn't have any trouble with the installation and was able to run all
of the samples using the axis2_http_server.exe application.

The Problem:
I modified the dynamic_client example to take all of the arguments
related to dynamic invocation (WSDL file, namespace, service URL,
operation, operation parameters, etc) from the command line and tested
it using the Calculator example and it worked.

When I changed the command line arguments to point to a remote service I 
started getting errors when the service client was being created.  I 
tried a couple of different things but got the same result.  Here's what 
I'm passing in:

axis2_svc_client_create_for_dynamic_invocation(
env,                   //the usual pointer to an environment variable
config_stx,            //In the example this is NULL, but the docs said
it should be a pointer to a configuration struct...so I created one,
although it's empty
wsdl_uri,              //The URI to the WSDL file which, based on the
output of AXIS2_URI_TO_STRING, WSDL URI is:
C:\axis2c\bin\samples\resources\jirasoapservice-v2.wsdl
wsdl_svc_qname        //The service qname which, based on the output of
AXIS2_QNAME_TO_STRING, QNAME is:
JiraSoapServiceService|http://jira.atlassian.com/rpc/soap/jirasoapservice-v2
progParams->ws_name //The web service name: "JiraSoapServiceService"
client_home          //The axis2c deploy location "C:\axis2c"
);

Note for wsdl_uri:  I had switched to a local WSDL URI but I got the 
same result regardless.  The remote WSDL URI was:
http://jira.atlassian.com/rpc/soap/jirasoapservice-v2?wsdl

The return from the function is, unfortunately, NULL (0x00000000).
Sometimes it goes into the error block and sometimes it results in an
unhandled exception in the AXIS_ENGINE.DLL: 0x00000005: Access Violation 
  .  I switched back to the original example and it still works.

I have changed the log output to DEBUG for logger but I don't see any 
difference in the output in the log file.  I also tried to get the error 
code from the env variable but the Access Violation error terminates the 
program.

So:
1)  Why do values for a local service work but not a remote service?
2)  What else do I need to change to get more debug information?
3)  Could the size of the WSDL file be a factor?
4)  Should I not use the binaries and build a local version of Axis2C?

Any help would be greatly appreciated (let me know if you need
additional information).

Thanks,

Cliff

-- 
Clifford Audinet
Software Architect

Stonebranch, Inc.
950 North Point Parkway
Suite 200
Alpharetta, Ga 30005
(678) 366-7887 X316
http://www.stonebranch.com
mailto:clifford.audinet@stonebranch.com




---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message