axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From m..@gmx.at
Subject Re: [axis2c] unable to startup mod_axis2
Date Sat, 27 Jan 2007 08:36:56 GMT
Hi Nabeel,
Thanks a lot for your answer. The problem was indeed with the repoPath (that cost me some
hours yesterday night gr!!! :-)).

Could I suggest a minor patch to the docs for the mod_axis2c (which is very good btw.).
With most other steps there is an example given, not so with httpd.conf of the installation
guide. thats why i thought the repo path must point directly to the services...
the axis2/c manual has the example btw.

i attach you a patched .html of the installation-guide maybe you can use it.

thanks,
mark



-------- Original-Nachricht --------
Datum: Fri, 26 Jan 2007 20:13:54 -0500
Von: "Nabeel Yoosuf" <nabeel.yoosuf@gmail.com>
An: "Apache AXIS C User List" <axis-c-user@ws.apache.org>
Betreff: Re: [axis2c] unable to startup mod_axis2

> Hi Mark,
> It seems that you have not set the repo path (Axis2RepoPath) correctly in
> httpd.conf.
>  Axis2RepoPath D:/cpp/axis2c (in your case)
> 
> The following details might be useful for you.
> 
> I have used apache2.2.x with axis2c-src-0.96 and it worked for me.
> Following
> are the changes I did.
> Having set the correct paths in configure.in, I switched off the following
> parameter. (ie. set to false)
> APACHE_VERSION_IS_2_0_59 = 0
> And copied the mod_axis2.dll to modules directory.
> 
> 
> My httpd.conf looks like as follows.
> 
> LoadModule axis2_module modules\mod_axis2.dll
>     Axis2RepoPath D:\axis2c-src-0.96\build\deploy
>     Axis2LogFile D:\axis2c-src-0.96\build\deploy\logs
>     Axis2LogLevel AXIS2_LOG_LEVEL_DEBUG
>     <Location /axis2>
>         SetHandler axis2_module
>     </Location>
> 
> 
> Nabeel.
> 
> On 1/26/07, mgt@gmx.at <mgt@gmx.at> wrote:
> >
> > hi guys,
> > thanks in advance for the great tool and all the help. much appreciated!
> >
> > i have been desperately trying to get mod_axis2 to work for the last
> > couple of hours and do not know what else to try next.
> >
> > first my setup:
> > winXP
> > apache 2.0.59 and apache 2.2.3
> > tried both axis2c-bin-0.96 and axis2c-src-0.96
> > axis2 source build at d:\cpp\axis2\
> > path includes d:\cpp\axis2\lib
> >
> > when building the sources on my machine simpleAxisServer and the
> examples
> > all run fine. when building the mod_axis2.dll and deploying it to the
> old
> > apache2 (2.0.59) the server hangs at startup and floods the apache
> > error.log with the following error msg:
> >
> > [Sat Jan 27 00:42:28 2007] [error] Parent: child process exited with
> > status 15 -- Aborting.
> > [Sat Jan 27 00:42:28 2007] [notice] Apache/2.0.59 (Win32) configured --
> > resuming normal operations
> > [Sat Jan 27 00:42:28 2007] [notice] Server built: Jul 27 2006 15:55:03
> > [Sat Jan 27 00:42:28 2007] [notice] Parent: Created child process 7352
> > [Sat Jan 27 00:42:28 2007] [notice] Child 7352: Child process is running
> > [Sat Jan 27 00:42:28 2007] [emerg] (20014)Error string not specified
> yet:
> > [Axis2] Error creating mod_axis2 apache2
> >
> > the axis log itself contains no entries...
> >
> > when i deploy th mod_axis2.dll to the newer apache version (2.2.3) the
> > server immediately exits after startup (with no error log entries).
> >
> > the names in my httpd.conf should be ok, at least i get graceful error
> > message from apache when something is wrong there (dll names,...). just
> to
> > make sure thats my httpd.conf:
> >
> > LoadModule axis2_module modules/mod_axis2.so
> >     Axis2RepoPath D:/cpp/axis2c/services
> >     Axis2LogFile D:/cpp/axis2c/logs
> >     Axis2LogLevel AXIS2_LOG_LEVEL_TRACE
> >     <Location /axis2>
> >         SetHandler axis2_module
> >     </Location>
> >
> > should i use different versions of axis2c or apache in order to work
> > together properly? do you have any other idea/hint/...?
> > thanks for your help in advance
> >
> > Mark
> >
> > --
> > Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
> > Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-c-user-help@ws.apache.org
> >
> >

-- 
"Feel free" - 5 GB Mailbox, 50 FreeSMS/Monat ...
Jetzt GMX ProMail testen: http://www.gmx.net/de/go/promail

Mime
View raw message