axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Popuri, Monica" <monica.pop...@hp.com>
Subject RE: Problem with deployment of calculator web service
Date Fri, 22 Sep 2006 06:27:30 GMT
Sorry I forgot to add the logs.. Please look at these.

 
Thanks,
Monica
 
 

-----Original Message-----
From: Popuri, Monica 
Sent: Thursday, September 21, 2006 5:43 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service


thanks, i guess i already have trace enabled and have AxisClientLog and AxisLog available
when I make any request. Please find them attached with this mail. The AxisClient.log will
show the messages when I call calcultator program from command line .
Please let me know if you want to see some more traces also.
 
Regards,
Monica
 

-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Thursday, September 21, 2006 5:31 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service



OK, that's great - now I understand exactly where we're up to :-) 

So, Now I think the next thing to do would be to run trace on the Axis server (see here  http://ws.apache.org/axis/cpp/TraceGuide.html).
You might want to try putting trace on at the client too if the server trace looks OK - i.e.
the server seems to be sending the complete response back. 

and also tcpmon so we can see if any response is being sent at all. 
Also, any apache trace you can get would be useful (but I can't remember how to do this!)








"Popuri, Monica" <monica.popuri@hp.com> 


21/09/2006 12:02 


Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>



To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 

cc

Subject
RE: Problem with deployment of calculator web service	

		




Hi John, 
there are some things I need to update you on my installation:
I have Axis C++ installed in a folder say /obj/package/axis-c-linux-bin. Tested calculator
sample with simple_axis_server , works fine. 
  
Now when I deploy in apache (1.0.3 this time) , I am still referring to same directory for
AXISCPP_HOME (/obj/package/axis-c-linux-bin). I just copy the libaxiscpp_mod.so in apache/libexec
folde . And have added the required LoadModules lines in httpd.conf file. 
Now when I run  <http://localhost/axis> http://localhost/axis I get 
  
  
"welcome to axis C++" 
"Deployment Descriptor not found" 
  
which means I am able to reach to my AXISCPP_HOME dir as axis_server.so is able to execute.
But it is giving this error (Deployment descriptor not found). Although when I see AxisClientLog
or AxisLog entried I see that it is able to read my server.wsdd correctly. because If I do
some changes in server.wsdd file they are reflected in this log file also. 
  
At the same time when I try to execute the calculator program with apache like : calculator
add 2 2  <http://localhost/axis/Calculator> http://localhost/axis/Calculator I get the
error as I mentioned : HTTPTransportException:Input streaming error while getting data Channel
error 104 while reading data: 'Connection reset by peer' 
  
Let me know if I need to give more details so that you can help me out. 
  
Many thanks, 
Monica 
  
  
  
  
  
-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Thursday, September 21, 2006 4:24 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service


Woh there - you're talking about two diff servers. I'm asking whether the server.wsdd for
the apache server (which is the one you said didn't work) was getting changed sucessfully.


If you tell me that you've got this working for Simple-axis-server then we're half way there
 (C version I assume?) 

How about you take the server.wsdd from the simple-axis-server  configuration and replace
the apache config file with it. 

Then, when you've done that. run the client again against apache but put tcpmon in-front of
it so you can capture the request and response -> http://ws.apache.org/commons/tcpmon/







"Popuri, Monica" <monica.popuri@hp.com> 


21/09/2006 10:55 



Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>




To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 

cc

Subject
RE: Problem with deployment of calculator web service	


		





yes, because I am able to execute calculator program successfully using simple_axis_server
. 
-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Thursday, September 21, 2006 3:24 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service


What do you mean by "perfectly alright"? Has it got the calculator service deployed or not?



"Popuri, Monica" <monica.popuri@hp.com> 


21/09/2006 10:45 



Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>





To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 

cc

Subject
RE: Problem with deployment of calculator web service	




		






server.wsdd is perfectly alright, I am deploying axis in Apache 1.0.3 So apache is only server
running.what should be changed for deploying manually? 
-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Thursday, September 21, 2006 3:02 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service


Connection reset by peer is the equivelant of the server putting the phone down which means
that you probably got to your server. 

Have you looked at the server.wssd file to see if it's changed? What server are you running?


If it hasn't changed then I'd be inclined to manually alter it just to deploy this service.



"Popuri, Monica" <monica.popuri@hp.com> 


21/09/2006 10:13 



Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>




To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 

cc

Subject
RE: Problem with deployment of calculator web service	





		







Hi John, I am not at all aware on how to resolve the socket/transport/network/config  related
error. A help is very much appriciated. 
-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Thursday, September 21, 2006 2:31 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service


If you don't have the channel defined in your conf file then make sure it's in your path (libpath
if unix) (you don't need ssl at this stage). I assume you have read the instructions on the
site - this is all described there I think. 
"Popuri, Monica" <monica.popuri@hp.com> 


21/09/2006 09:44 



Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>





To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 

cc

Subject
RE: Problem with deployment of calculator web service	






		








By sample I meant calculator etc. By any chance, can this error be linked with absence of
Channel_HTTP_SSL or Channel_SSL parameters in axiscpp.conf file? 

-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Thursday, September 21, 2006 2:10 PM
To: Apache AXIS C User List
Subject: RE: Problem with deployment of calculator web service


Yes - this is almost certainly a socket/transport/network/config error. 

You've started me on a different track now by saying that you are trying the samples. Which
samples? Have you ensured that they are deployed on the server? 
"Popuri, Monica" <monica.popuri@hp.com> 


21/09/2006 06:41 



Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>




To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 

cc

Subject
RE: Problem with deployment of calculator web service	







		









Hi John, 

Actually I also get same error for all of sample programs. You still feel that this can be
platform related issue? 

With Regards, 
Monica 
-----Original Message-----
From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com]
Sent: Wednesday, September 20, 2006 6:16 PM
To: Apache AXIS C User List
Subject: Re: Problem with deployment of calculator web service


this is a transport/socket problem - You'll have to find out what channel error 104 means
for your particular platform. 
Murali Konnipati <murali.konnipati@altair.com> 


20/09/2006 13:13 



Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>





To
Apache AXIS C User List <axis-c-user@ws.apache.org> 

cc

Subject
Problem with deployment of calculator web service	








		










Hi All, 

    When i try to deploy the calculator sample usign AdminClient program, it is giving me
the following error.. 

     Exception :  HTTPTransportException:Input streaming error while getting data Channel
error 104 while reading data: 'Connection reset by peer' 

  My deploy.wsdd file is.. 

  <?xml version="1.0" encoding="UTF-8"?>
<deployment xmlns="  <http://xml.apache.org/axis/wsdd/> http://xml.apache.org/axis/wsdd/"
xmlns:CPP="  <http://xml.apache.org/axis/wsdd/providers/CPP> http://xml.apache.org/axis/wsdd/providers/CPP">
 <service name="Calculator" provider="CPP:RPC" description="Axis C++ web service">
         <parameter name="className" value="/usr/local/axiscpp_deploy/samples/calculator/libcalculator.so"/>
         <parameter name="allowedMethods" value="add addRequest sub subRequest mul mulRequest
div divRequest "/>
 </service>
</deployment> 

  Could any body please help me in this regard, 

Thanks & Regards, 

Murali Krishna K 



Mime
View raw message