axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas URIEN <nicolas.ur...@acoss.fr>
Subject java.lang.NoSuchMethodError witch WSDL2ws
Date Thu, 20 Jul 2006 06:54:19 GMT

Hi,

I have created a web service with the java axis tool.
It works fine from a java client.

Now , I need to make a C/C++ program.

I got this exception raised when running the WSDL2ws in order to make my C
stubs:

Exception in thread "main" java.lang.NoSuchMethodError:
org.apache.axis.wsdl.symbolTable.BindingEntry.getBindingStyle()Lorg/apache/axis/enum/Style;
      at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.setMethodInfo(Unknown Source)
      at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.getServiceInfo(Unknown
Source)
      at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.generateWrappers(Unknown
Source)
      at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.main(Unknown Source)


Here are my arguments :

-sclient -v ${project_loc}/src/WebServiceAncre.wsdl

I run this command from Eclipse. It has the other required axis libraries
(axis.jar, commons-*, jaxrpc etc..) in its classpath (I have tried
both axis 1.6 beta and 1.6 without success)

What is wrong please?

Help will be greatly appreciated. Many thanks in advance.
Mime
View raw message