axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chintana Wilamuna" <chinta...@gmail.com>
Subject Re: [Axis2]Re: Library linking problem
Date Wed, 12 Jul 2006 10:10:18 GMT
On 7/12/06, Sahan Gamage <sahan@wso2.com> wrote:

> I see. I was thinking that you are writing a Ruby wrapper in C and I was
> mentioning the Makefile.am of that component. Seems like I have mistaken :)

:-)

> What library (or more specifically the .so file)  you're trying to load
> ? Axis2 libraries have a dependency hierachy.

I'm loading the libraries in the following order,

libaxis2_util.so
libaxis2_axiom.so
libaxis2_http_receiver.so
libaxis2_wom.so
libaxis2_wsdl.so
libaxis2_parser.so
libaxis2_minizip.so
libaxis2_libxml2.so
libaxis2_http_sender.so
libaxis2_engine.so

And these are all that there in my deploy/libs folder.  I'm loading
all of them to get fewer surprises.

> For example :
> axis2_unix <= axis2_util <= axis2_om (where a <= b means b depends on a).
> also
> libxml2 <= axis2_libxml2 <= axis2_om
> And the dependency tree continues .....

I don't see a library named libaxis2_om.so or libaxis2_unix.so in 0.92
binary/source, however I can see those in 0.91 binary/source

I tried loading libraries in 0.91 and it gives the exact same error
message on previously mentioned libraries plus it gives,

libaxis2_parser.so: undefined symbol: xmlFree

> So IMHO you have to load dependencies before loading the required library.

I doubt it because with 0.91 release I could load libaxis2_om.so first
and then load libaxis2_unix.so without a problem.

To make matters a bit more confusing I could load the
libaxis2_parser.so library in 0.92 release without a problem!

Bye,

    -Chintana

-- 
http://chintana.wordpress.com/
http://www.linux.lk/~chintana/

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-c-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-c-user-help@ws.apache.org


Mime
View raw message