axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiong, Zhikang" <xio...@ugs.com>
Subject RE: Problem in C++ interaction to java webservice over SSL
Date Fri, 16 Jun 2006 22:14:53 GMT
I just changed my program to use Axis-C 1.5 (it was 1.6b before), and it stopped working! I
then did a search and found this is a bug in 1.5 for SSL web service, someone found it and
already had a fix for it: http://www.mail-archive.com/axis-c-user@ws.apache.org/msg01257.html.
Apparently, this fix has been included in 1.6b, but we can't use it in production environment
since it's a beta release.
 
Does anyone know when Axis-C 1.6 will be released? If I can't wait for that, I probably need
to try another toolkit (like gSoap).
 
Thanks,
Jude

________________________________

From: Xiong, Zhikang
Sent: Tue 6/13/2006 10:59 AM
To: SKUNNIKURU@maine.rr.com; axis-c-user@ws.apache.org
Subject: RE: Problem in C++ interaction to java webservice over SSL


I don't know what caused the problem but for your information, I was able to call a secured
Java web service (hosted by a websphere server) by using the Axis-C 1.6b version. I didn't
import or set up any certificate (but I did import the cert when working on a Java client
program accessing the same web service). I'm sure that I didn't use the gskit neither.
 
I'm not sure if the problem is related to certificate, but if so, shouldn't the error message
be something like "Not trusted server..."?
 
Thanks,
Jude

________________________________

From: SKUNNIKURU@maine.rr.com [mailto:SKUNNIKURU@maine.rr.com]
Sent: Thu 6/8/2006 8:13 PM
To: axis-c-user@ws.apache.org
Subject: Problem in C++ interaction to java webservice over SSL



Iam having a problem using Axis CPP client interacting
with a Java web service.I am getting "Not found" error
when I call my Java web service(websphere environment)
from C++ client(axis C++ toolkit) over https, it works
without any problem using the Http. I am wondering if
it is related to SSL certificates. What value should
be in the Secureinfo parameter in the axiscpp.conf? I
converted my server certificate to OpenSSL format and
entered the filename in the OpenSSL format to my
openSSL.cnf. Will the value for the certificate be
taken from axiscpp.conf or the SecureInfo parameter in
the axiscpp.conf. I have AXIS_DEPLOY and
Channel_HTTP_SSL parameter set correctly and HTTP
secure dll loads without any problem. I have the
latest version of Axis(1.5).I also saw a mention of
gskit as a prerequisite for C++ web client in the ibm
site.Is gskit a prerequisite for Axis C++ client, when
i needs to interact with a webservice in a secure
webserver(https)?

Any info will be highly appreciated.

Thanks

Santosh.







Mime
View raw message