axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yair Zaslavsky" <y...@imagine-com.com>
Subject Axis can't find my xerces library
Date Wed, 07 Jun 2006 12:17:31 GMT
I downloaded xerces-c 2.2.0, and built it.

I downloaded the axis distribution for linux (our machine is 64 bit,
little endian, and we're running redhat).

When I try to run the axis simple server it fails to locate the xerces
library - libxerces-c.so.22 

 

Here is  additional information agbout the configuration, I just cant
see what I'm doing wrong ...

 

echo $XERCESCROOT

/home/yair/xerces-c-src2_2_0/xerces-c-src2_2_0

 

echo $XERCESHOME

/home/yair/xerces-c-src2_2_0/xerces-c-src2_2_0

 

echo $LD_LIBRARY_PATH

:/home/yair/xerces-c-src2_2_0/xerces-c-src2_2_0/lib:/home/yair/axis_bin/
axis-c-linux-current-bin/axis-c-1.6b-Linux-trace-bin/lib:/home/yair/axis
_bin/axis-c-linux-current-bin/axis-c-1.6b-Linux-trace-bin/lib/axis

 

echo $AXISCPP_DEPLOY

/home/yair/axis_bin/axis-c-linux-current-bin/axis-c-1.6b-Linux-trace-bin

 

 

more axisconf.deploy

# Path to server trace log path (only required if you want server trace)

LogPath:/home/yair/axis_server.log

 

# Path to HTTP Transport library

Transport_http:/home/yair/axis_bin/axis-c-linux-current-bin/axis-c-1.6b-
Linux-trace-bin/lib/axis/libhttp_transport.so

 

# Path to Axis XML Parser library

XMLParser:/home/yair/axis_bin/axis-c-linux-current-bin/axis-c-1.6b-Linux
-trace-bin/lib/axis/libaxis_xerces.so

 

A part of the startup log , showing the exception:

 

 

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException >
getMessageForExceptionCode @0xffffcef0,29

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException <
getMessageForExceptionCode @0xffffcef0,"DLOPEN FAILED in loading parser
library"

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException >
getMessageForExceptionCode @0xffffcef0,29

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException <
getMessageForExceptionCode @0xffffcef0,"DLOPEN FAILED in loading parser
library"

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException <
AxisEngineException @0xffffcef0

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException >
AxisEngineException @0x8058760,------------>

[07/06/2006 15:09:46:214 IDT] 4159387328 - I AxisException(_, "DLOPEN
FAILED in loading parser library DLOPEN FAILED in loading parser library
Failed to load parser within server engine: 

[07/06/2006 15:09:46:214 IDT] 4159387328 - I                  Error
Message='Success'                Error Code='0'

[07/06/2006 15:09:46:214 IDT] 4159387328 - I                  Load lib
error='libxerces-c.so.22: cannot open shared object file: No such file
or directory' 

[07/06/2006 15:09:46:214 IDT] 4159387328 - I ")

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException <
AxisEngineException @0x8058760

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException >
~AxisEngineException @0xffffcef0

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException <
~AxisEngineException @0xffffcef0

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException >
~AxisEngineException @0x8058408

[07/06/2006 15:09:46:214 IDT] 4159387328 AxisEngineException <
~AxisEngineException @0x8058408

[07/06/2006 15:09:46:214 IDT] 4159387328 - X initialize_module @3 caught
"..."

 

 

I would really appreciate if someone can help me,

 

Thanks

 

Yair

 


Mime
View raw message