axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ignacio Fernández Sánchez" <ignaciof...@gmail.com>
Subject Re: SIGABRT on Axis C++ client
Date Tue, 23 May 2006 09:35:31 GMT
My enviroment are:

============================================================

LD_LIBRARY_PATH=/usr/local/sbin/xerces-2_2_0/lib:/usr/local/sbin/axis-cpp2/lib/axis:

JAVA_HOME=/usr/local/java

CLASSPATH=/usr/local/java/lib:/usr/local/sbin/axis-cpp2/lib/wsdl2ws.jar:/usr/local/sbin/axis-cpp2/lib/axis.jar:/usr/local/sbin/axis-cpp2/lib/commons-
discovery.jar:/usr/local/sbin/axis-cpp2/lib/commons-logging.jar:/usr/local/sbin/axis-cpp2/lib/jaxrpc.jar:/usr/local/sbin/axis-cpp2/lib/saaj.jar:/usr/local/sbin/axis-cpp2/lib/wsdl4j.jar:/usr/local/sbin/axis-cpp2/lib/xml-apis.jar:/usr/local/sbin/axis-cpp2/lib/xercesImpl.jar:/usr/local/sbin/axis-cpp2/lib/activation.jar:/usr/local/sbin/axis-cpp2/lib/log4j-1.2.8.jar:

AXISCPP_DEPLOY=/usr/local/sbin/axis-cpp2/deploy
----------------------------------------

Ignacio.

2006/5/23, John Hawkins <HAWKINSJ@uk.ibm.com>:
>
>
> Usually an issue at this point is caused by the correct level xerces libs
> not being in the lib path.
>
>
>
>
>  *"Ignacio Fernández Sánchez" <ignaciofedz@gmail.com>*
>
> 23/05/2006 10:13  Please respond to
> "Apache AXIS C User List" <axis-c-user@ws.apache.org>
>
>   To
> axis-c-user@ws.apache.org  cc
>
>  Subject
> SIGABRT on Axis C++ client
>
>
>
>
>
>
> I search into the mail list and I found the same problem that my but I
> didn't resolve the problem. This is the post:
> *
> **
> http://mail-archives.apache.org/mod_mbox/ws-axis-c-user/200602.mbox/%3c43FA5065.6070008@simdesk.com%3e
> *<http://mail-archives.apache.org/mod_mbox/ws-axis-c-user/200602.mbox/%3c43FA5065.6070008@simdesk.com%3e>
>
> I use axis cpp 1.6 the binary file on a debian sarge kernel version 2.6(with an Intel
P4M procesor).
>
>
> =========================================================================================
> ~$ uname -a
> Linux debian 2.6.8-2-386 #1 Thu May 19 17:40:50 JST 2005 i686 GNU/Linux
> -------------------------------------------
>
> *The gdb out put is:*
>
> =========================================================================================
> ~$gdb echo
> Starting program: /home/nacho/webServices/prueba3/echo
> [Thread debugging using libthread_db enabled]
> [New Thread 1077393984 (LWP 4762)]
>
> Program received signal SIGABRT, Aborted.
> [Switching to Thread 1077393984 (LWP 4762)]
> 0x4025f83b in raise () from /lib/tls/libc.so.6
> (gdb) bt
> #0  0x4025f83b in raise () from /lib/tls/libc.so.6
> #1  0x40260fa2 in abort () from /lib/tls/libc.so.6
> #2  0x401e3f57 in __cxa_call_unexpected () from /usr/lib/libstdc++.so.5
> #3  0x401e3f94 in std::terminate () from /usr/lib/libstdc++.so.5
> #4  0x401e416c in __cxa_rethrow () from /usr/lib/libstdc++.so.5
> #5  0x400bf8ab in initialize_module () from
> /usr/local/sbin/axis-cpp2/lib/axis/libaxis_client.so
> #6  0x400c1e6c in axiscpp::Call::Call () from
> /usr/local/sbin/axis-cpp2/lib/axis/libaxis_client.so
> #7  0x400a45eb in axiscpp::Stub::Stub () from
> /usr/local/sbin/axis-cpp2/lib/axis/libaxis_client.so
> #8  0x0804919e in MyService::MyService ()
> #9  0x08049053 in main ()
>
> -------------------------------------------
> *
> And  my axis.conf file:*
>
>
> =========================================================================================
> LogPath:/usr/local/sbin/axis-cpp2/deploy/log/AxisLog
> ClientLogPath:/usr/local/sbin/axis-cpp2/deploy/log/AxisClientLog
> XMLParser:/usr/local/sbin/axis-cpp2/deploy/lib/libxerces-c.so
> Transport_http:/usr/local/axis-cpp2/lib/axis/libhttp_transport.so
> -------------------------------------------
>
> I only want to use axis cpp on the client side, the ws server side
> implements axis java.
>
> What's wrong? Thanks a lot for your help!
>
> Ignacio.
>
>
>

Mime
View raw message