axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Galataud" <antoine.galat...@gmail.com>
Subject Re: Axis C++ and Solaris... feedback
Date Mon, 06 Mar 2006 15:15:47 GMT
Ok !! It works !!!

With 1.6a.n !

Seems it's a bug, because the client can't open a connection (open a socket)
on a port > 32000 (something like that, I didn't verified the exact number).
So, apache was running on 64010, it was bad.
I verified with some home made samples in cpp and java, the connections work
for ports >32000. So i guess it's an axis bug. Could you confirm ?

Thanks

2006/3/6, Antoine Galataud <antoine.galataud@gmail.com>:
>
> Hi all !
>
> I'm still searching for a solution to my client problem (SIGABRT)
> received. I think I'm near the problem, but i need help to solve it !
>
> In fact, exception thrown by client is HTTPTransportException, and it
> seems to be thrown in HTTPChannel::OpenChannel(). But I don't know exactly
> where.
> Here is my client log :
>
> [06/03/2006 12:10:53:808 MET] 1 HTTPTransport > openConnection @248e8
> [06/03/2006 12:10:53:808 MET] 1 HTTPChannel > open @249c8
> [06/03/2006 12:10:53:809 MET] 1 HTTPChannel > OpenChannel @249c8
> [06/03/2006 12:10:53:809 MET] 1 URL > getHostName
> [06/03/2006 12:10:53:809 MET] 1 URL < getHostName "localhost"
> [06/03/2006 12:10:53:809 MET] 1 URL > getPort
> [06/03/2006 12:10:53:809 MET] 1 URL < getPort 64010
> [06/03/2006 12:10:53:877 MET] 1 HTTPTransportException >
> HTTPTransportException @fefea988,54, <null>
> [06/03/2006 12:10:53:878 MET] 1 HTTPTransportException >
> getMessageForExceptionCode @fefea988,54
> [06/03/2006 12:10:53:878 MET] 1 HTTPTransportException <
> getMessageForExceptionCode @fefea988,"HTTPTransportException:Unknown
> Transport Exception"
> [06/03/2006 12:10:53:878 MET] 1 HTTPTransportException <
> HTTPTransportException @fefea988
> [06/03/2006 12:10:53:878 MET] 1 ClientAxisEngine X process @24a88,caught
> AxisException(6, "HTTPTransportException:Unknown Transport Exception")
> [06/03/2006 12:10:53:879 MET] 1 AxisGenException > AxisGenException
> @fefea9e0,54, "HTTPTransportException:Unknown Transport Exception"
> [06/03/2006 12:10:53:879 MET] 1 AxisGenException >
> getMessageForExceptionCode @fefea9e0,54
> [06/03/2006 12:10:53:879 MET] 1 AxisGenException <
> getMessageForExceptionCode @fefea9e0,""
> [06/03/2006 12:10:53:879 MET] 1 AxisGenException >
> getMessageForExceptionCode @fefea9e0,54
> [06/03/2006 12:10:53:879 MET] 1 AxisGenException <
> getMessageForExceptionCode @fefea9e0,""
> [06/03/2006 12:10:53:879 MET] 1 AxisGenException < AxisGenException
> @fefea9e0
> [06/03/2006 12:10:53:879 MET] 1 HTTPTransportException >
> ~HTTPTransportException @fefea988
> [06/03/2006 12:10:53:880 MET] 1 HTTPTransportException <
> ~HTTPTransportException @fefea988
> [06/03/2006 12:10:53:880 MET] 1 SoapFaultException > SoapFaultException
> @fefeaa38,AxisException(6, " HTTPTransportException:Unknown Transport
> Exception")
> [06/03/2006 12:10:53:880 MET] 1 SoapFaultException < SoapFaultException
> @fefeaa38
>
> it is said as an unknown transport exception, but i can guess it is when
> connection is opened, maybe when socket is opened.
>
> Some more details : the server is running on http://localhost:64010/axis
> the service Calculator provides add(int,int) method at
> http://localhost:64010/axis/Calculator#add
>
> In the file Calculator.cpp generated by wsdl2ws, i tried to set endpoint
> uri to "http://localhost:64010/axis" or even "http://localhost:64010/axis/Calculator
> "
>
> What can be the possible cause(s) of this problem ?
>
> Thanks in advance !
>
> 2006/3/3, Antoine Galataud <antoine.galataud@gmail.com >:
> >
> > I forgot : i also had to relink libaxiscpp_mod.so, cause some libs were
> > missing
> > like this :
> > CC -qoption ld -i -o libaxiscpp_mod.so -G -lCrun -lCstd /axis/axis-
> > c-1.6a.n-SunOS-trace-bin/lib/axis/libaxiscpp_mod.so
> >
> > 2006/3/3, Antoine Galataud < antoine.galataud@gmail.com>:
> >
> > > ok, i tried with :
> > > - 1.6a.n binary release for SunOS
> > > - calculator example
> > > - xerces 2.2.0
> > >
> > > I'm stuck again with the "same" error : when i run the calculator
> > > sample, i get a SIGABRT; here is my debugger output :
> > > Reading calculator
> > > Reading ld.so.1
> > > Reading libdl.so.1
> > > Reading libaxis_client.so
> > > Reading libCstd.so.1
> > > Reading libCrun.so.1
> > > Reading libm.so.1
> > > Reading libw.so.1
> > > Reading libc.so.1
> > > Reading libsocket.so.1
> > > Reading libnsl.so.1
> > > Reading libmp.so.2
> > > Reading libCstd_isa.so.1
> > > Reading libc_psr.so.1
> > > (dbx)
> > > run
> > > Running: calculator
> > > (process id 21159)
> > > Reading libaxis_xerces.so
> > > Reading libxerces-c.so.22
> > > Reading libpthread.so.1
> > > Reading libthread.so.1
> > > detected a multithreaded program
> > > Reading libhttp_transport.so
> > > Reading libhttp_channel.so
> > > Reading nss_files.so.1
> > > Reading nss_nis.so.1
> > > Exception of type <unknown type> is unhandled
> > > t@1 (l@1) stopped in __exdbg_notify_of_throw at 0xfefd3d94
> > > 0xfefd3d94: __exdbg_notify_of_throw       :     jmp     %o7 + 0x8
> > >
> > > Unfortunatly, i don't have much time to see where exactly exception
> > > occurs, but i guess it's probably at the same point (or nearly)
> > >
> > > My stub and skeleton compilation options :
> > > Skeleton :
> > >  CC -qoption ld -i -o libcalc.so -xO3 -xlibmil -xlibmopt -DNDEBUG
> > > -xildoff -DNDEBUG -DSYSV -DSVR4 -Dsolaris -DANSI_C -D_TEMPLATES_ENABLE_ -mt
> > > -D_POSIX_THREADS -D_REENTRANT -DEXCEPTION_EXPORTS -PIC -G -I../../include
> > > *.cpp
> > >
> > > Stub :
> > > CC *.cpp -I../include -L /axis/axis-c-1.6a.n-SunOS-trace-bin/lib/axis
> > > -ldl -laxis_client -o calculator
> > >
> > > my axiscpp.conf :
> > > WSDDFilePath:/axis/etc/server.wsdd
> > > XMLParser:/axis/axis-c-1.6a.n-SunOS-trace-bin/lib/axis/libaxis_xerces.so
> > > LogPath:/log/AxisLog
> > > ClientLogPath:/axis/log/AxisClientLog
> > > ClientWSDDFilePath:/axis/etc/client.wsdd
> > > Transport_http:/axis/axis-c-1.6a.n-SunOS-trace-bin/lib/axis/libhttp_transport.so
> > >
> > > Channel_HTTP:/axis/axis-c-1.6a.n-SunOS-trace-bin
> > > /lib/axis/libhttp_channel.so
> > >
> > > my server.wsdd :
> > > <?xml version="1.0" encoding="UTF-8"?>
> > > <deployment xmlns=" http://xml.apache.org/axis/wsdd/" xmlns:C="http://xml.apache.org/axis/wsdd/providers/C
> > > " xmlns:CPP=" http://xml.apache.org/axis/wsdd/providers/CPP">
> > >     <globalConfiguration>
> > >     </globalConfiguration>
> > >     <service name="Calculator" provider="CPP:RPC"
> > > description="Calculator Web Service">
> > >         <parameter name="allowedMethods" value="add"/>
> > >         <parameter name="className"
> > > value="/apache/webservices/libcalc.so"/>
> > >     </service>
> > > </deployment>
> > >
> > > Once again, i have no way to verify that my webservice is up and
> > > correctly deployed by apache without testing with a client, so i can't
> > > figure out if it's a client bug or server bug.
> > > With simple_axis_server, if i open its url in a browser, it does
> > > nothing. If i start the client, same bug, unless the browser requests it,
> > > then it waits
> > >
> > > I also found another bug in 1.5 release : axiscpp.conf is not
> > > correctly parsed (it's not an encoding problem, i checked) : if i let
> > > comments (with #), the file is just not parsed.
> > >
> > > One other question : for tests, do you use gcc on Solaris or do you
> > > use native CC (in buildInitialize.xml, it's set at CC) ?
> > >
> > > Thank again for help, hope we could fix those bugs rapidly !
> > >
> > >
> > > 2006/3/3, Antoine Galataud < antoine.galataud@gmail.com >:
> > >
> > > > Ok so i tried with 2.2.0 xerces release, it changed nothing. I will
> > > > try to do some more tests, and post my results.
> > > >
> > > > 2006/3/3, Antoine Galataud < antoine.galataud@gmail.com>:
> > > >
> > > > > Thank for your response,
> > > > >
> > > > > I will try to open a bug report and give patches as soon as
> > > > > possible.
> > > > > For my error, i compiled axis c++ with xerces 2.5, and the lib is
> > > > > correctly loaded at run time. So, i don't think it's that. Maybe
opening bug
> > > > > will help to have a faster answer
> > > > >
> > > > > 2006/3/3, John Hawkins < HAWKINSJ@uk.ibm.com>:
> > > > >
> > > > > >
> > > > > > Many thanks for the feedback !
> > > > > >
> > > > > > Can you supply patches for these issues - opening JIRA's for
> > > > > > each problem and attaching the fix would be great !
> > > > > >
> > > > > > Re the sigabort in invoke - this is usually because you don't
> > > > > > have either the right version of xerces in your path or it's
not there at
> > > > > > all.
> > > > > >
> > > > > > many thanks again,
> > > > > > John.
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >  *"Antoine Galataud" <antoine.galataud@gmail.com>*
> > > > > >
> > > > > > 03/03/2006 11:20  Please respond to
> > > > > > "Apache AXIS C User List" <axis-c-user@ws.apache.org>
> > > > > >
> > > > > >   To
> > > > > > axis-c-user@ws.apache.org  cc
> > > > > >
> > > > > >  Subject
> > > > > > Axis C++ and Solaris... feedback
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > Hi,
> > > > > >
> > > > > > first of all, i want to thank developpers of this project, which
> > > > > > is
> > > > > > great and will become a reference.
> > > > > >
> > > > > > I'm too a developper, trying to replace a CORBA communication
> > > > > > layer in
> > > > > > a big application by WS (for interop purposes, particularly
at
> > > > > > compilation time, AIX is not well supported with may CORBA
> > > > > > distributions).
> > > > > > We decided to choose Axis as a webservices framework and
> > > > > > provider, and
> > > > > > started to work on a Solaris 8 system with Axis C++ 1.5 release.
> > > > > >
> > > > > > We dealed with a lot of problems ! We found syntax pb :
> > > > > > - in HandlerChain.hpp, bug described in mailing list, resolved
> > > > > > - in StubC.hpp : some static_cast are leading to compil. errors
> > > > > > (we
> > > > > > replaced them by dynamic ones)
> > > > > >
> > > > > > We found link pb (maybe it's only for us) : we had to add -lCrun
> > > > > > and
> > > > > > -lCstd to linker args to fit our needs.
> > > > > >
> > > > > > We managed to compile mod_axis for apache support, deployed
it,
> > > > > > and it
> > > > > > seems ok. The problem here is that we have no way to verify
it's
> > > > > > deployed until we test it with a client.
> > > > > > The second problem comes here : we generated stubs and skeletons
> > > > > > for
> > > > > > client and server parts, we compiled, seems ok. But we receive
> > > > > > SIGABRT
> > > > > > at runtime for the client. with a little debugging and tracing,
> > > > > > we
> > > > > > found that the exception is thrown at
> > > > > > ClientAxisEngine::invoke(MessageData* pMsg).
> > > > > >
> > > > > > Maybe there are answers for all those problems. It also would
be
> > > > > > great
> > > > > > to have feedback from other axis c++ users that tryied on a
> > > > > > Solaris
> > > > > > server.
> > > > > >
> > > > > > Thanks to all
> > > > > > --
> > > > > > Antoine Galataud
> > > > > > antoine.galataud@gmail.com
> > > > > > D�partement Architecture des Syst�mes d'Information
> > > > > > INSA - Rouen
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Antoine Galataud
> > > > > antoine.galataud@gmail.com
> > > > > D�partement Architecture des Syst�mes d'Information
> > > > > INSA - Rouen
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > Antoine Galataud
> > > > antoine.galataud@gmail.com
> > > > D�partement Architecture des Syst�mes d'Information
> > > > INSA - Rouen
> > > >
> > >
> > >
> > >
> > > --
> > > Antoine Galataud
> > > antoine.galataud@gmail.com
> > > D�partement Architecture des Syst�mes d'Information
> > > INSA - Rouen
> > >
> >
> >
> >
> > --
> > Antoine Galataud
> > antoine.galataud@gmail.com
> > D�partement Architecture des Syst�mes d'Information
> > INSA - Rouen
>
>
>
>
> --
> Antoine Galataud
> antoine.galataud@gmail.com
> Département Architecture des Systèmes d'Information
> INSA - Rouen
>



--
Antoine Galataud
antoine.galataud@gmail.com
Département Architecture des Systèmes d'Information
INSA - Rouen
Mime
View raw message