axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hawkins <HAWKI...@uk.ibm.com>
Subject Re: AIX 32 bit built
Date Wed, 22 Mar 2006 17:31:01 GMT
Nope. Because we're upgrading to a new version of xerces we need to do 
this across all platforms and we're having problems against simple-axis 
server on windows.

Can you build it yourself on aix? It might be quicker for you.







"Antoine Galataud" <antoine.galataud@gmail.com> 
22/03/2006 17:23
Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>


To
"Apache AXIS C User List" <axis-c-user@ws.apache.org>
cc

Subject
Re: AIX 32 bit built






Hi !

So, is this release ready for download ?

Thanks

2006/3/21, Antoine Galataud <antoine.galataud@gmail.com>: 
Thanks a lot !

2006/3/21, John Hawkins < HAWKINSJ@uk.ibm.com>:

Xerces 2.7 worked fine. 

We'll upgrade the build to use this asap. 






"Antoine Galataud" <antoine.galataud@gmail.com> 
21/03/2006 08:54 

Please respond to
"Apache AXIS C User List" <axis-c-user@ws.apache.org>



To
"Apache AXIS C User List" <axis-c-user@ws.apache.org> 
cc

Subject
Re: AIX 32 bit built








Hi,

It could be great to upgrade binaries on website, so a end-user can
take it, develop, and run. In my opinion, you should provide both
source and binary release, and giving advice about how to compile
correctly the source one.
For the binary release, it could be easier to have a built version in
accordance with the xerces binary release (it seams logical).

Thanks for your answer.
2006/3/20, John Hawkins <HAWKINSJ@uk.ibm.com>:
>
> Hi Folks,
>
> Quite a few people have been having trouble with the aix binaries we've 
got
> on the site at the moment (and we thought  we were doing everyone a 
favour
> ;-)
>
>
>
> Looks like the issue with the aix 32 bit build is this:
>
> The xerces build on the apache website was built using xmlC 5.*. The 
machine
> that we build the aix release code on uses 6.* and so we compiled xerces 
to
> use that compiler level also. Therefore, what we are seeing is the
> incompatibility of name mangling (or compiler options) between compiler
> levels.
>
> Given that I don't know how to get around this issue i.e. tell the xlc 
at
> 6.* level to mangle the same somehow (or use the same options?) We have 
two
> ways forward either
> a) Compile your own version of xerces 2_2_0 for AIX using xlc 6.*
> b) We'll also look into upgrading the version of xerces to be the latest 
and
> the binaries for this already use xlc 6.*
>
>
> I'll get back to you on how well the tests go for option b) but you can
> always continue with option a) yourselves :-)
>
> cheers for now,
> John.


--
Antoine Galataud
antoine.galataud@gmail.com
Département Architecture des Systèmes d'Information
INSA - Rouen




-- 

Antoine Galataud
antoine.galataud@gmail.com
Département Architecture des Systèmes d'Information
INSA - Rouen 



-- 
Antoine Galataud
antoine.galataud@gmail.com
Département Architecture des Systèmes d'Information
INSA - Rouen 

Mime
View raw message