axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cooper_Jo...@emc.com
Subject RE: Axis C++ with Apache on XP
Date Fri, 02 Dec 2005 14:35:20 GMT
Don, this is a red herring. The problem is that you don't have your paths
set correctly for all of the supporting dlls for the your service and the
axis core. Make sure that all of the dll locations are in your path, e.g.
C:\program files\apache group\apache\lib;C:\program files\apache
group\apache\axis\lib;... etc.
Thanks,

John 

4400 Computer Drive
2nd floor, Mailstop D239
Ext:   35983


-----Original Message-----
From: don.edgley@jpmchase.com [mailto:don.edgley@jpmchase.com] 
Sent: Friday, December 02, 2005 7:39 AM
To: axis-c-user@ws.apache.org
Subject: Axis C++ with Apache on XP


Hi,

I tried to get Axis to work on XP following the windows installation guide.
I followed the instructions very carefully (and also added an AXIS_HOME
environment variable) but Apache fails to start unless I remove this line:

LoadModule axis_module modules/mod2_axis.dll    in the httpd.conf file.

With the line in the file it gives this error:

C:\Program Files\Apache Group\Apache2\bin>Apache.exe
Syntax error on line 956 of C:/Program Files/Apache
Group/Apache2/conf/httpd.conf:
Cannot load C:/Program Files/Apache Group/Apache2/modules/mod2_axis.dll
into server: The specified module could not be found.

Putting mod2_axis.dll into dependency walker produces an error.

As far as I can tell this is complaining about the mpr.dll  - the file is
present in the system32 directory of windows (version 5.1.2600.0). The
message says:
Error: at least one module has an unresolved import due to a missing export
function
in a delay-load dependent module (WNetRestoreConnectionA is red).

I'm not really in a position to reinstall my operating system. Would this
count as
being a bug and can you give me any advice as to how to resolve this?

Many thanks,

Don

Mime
View raw message