axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hawkins <HAWKI...@uk.ibm.com>
Subject Re: Invalid Address error
Date Wed, 30 Nov 2005 10:41:34 GMT
k, yes - just checking :-)

I didn't ask what version of axis C ?







Clarence Dahlin <clarence.pitch@gmail.com> 
30/11/2005 10:06
Please respond to
"Apache AXIS C User List"


To
Apache AXIS C User List <axis-c-user@ws.apache.org>
cc

Subject
Re: Invalid Address error






Axis Java which I believe that I need to use wsdl2ws, right?


On 11/30/05, John Hawkins <HAWKINSJ@uk.ibm.com> wrote:

When you say Axis 1_2 do you mean axis java or axis C? 






Clarence Dahlin <clarence.pitch@gmail.com> 
30/11/2005 09:42 

Please respond to
"Apache AXIS C User List"



To
axis-c-user@ws.apache.org 
cc

Subject
Invalid Address error








Hi,

Does anyone know what I could try to fix this error?

HEAP[HelloAxisCpp.exe]: Invalid Address specified to RtlFreeHeap( 
00370000, 10080F0C )

I have a simple hello service (document/literal wrapped) running under 
Tomcat/Axis and I successully generated the cpp stubs with wsdl2ws.

I had to use an older version of axis1_2 though, beta3.

I've added the generated stubs to a visual studio .net project (7.1) and 
it compiles and links with a couple of warnings, but no errors.

It fails in this generated code:
HelloServicePortTypes::HelloServicePortTypes()
:Stub(" ", APTHTTP1_1)
{
   m_pCall->setEndpointURI("
http://enterprise:8383/axis/services/HelloService") ;
}

kind regards,
Clarence 


Mime
View raw message