axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <samisa.abeysin...@gmail.com>
Subject Re: installation problem
Date Mon, 10 Oct 2005 13:44:00 GMT
Pawel Pustelnik wrote:

> On Sun, 09 Oct 2005 23:21:54 +0200, Samisa Abeysinghe  
> <samisa.abeysinghe@gmail.com> wrote:
>
>> Pawel Pustelnik wrote:
>>
>>> Hi all,
>>>
>>> I have similar problem to Michael's (Michael Kipper
>>> [mailto:mkipper@rogers.com]) one.
>>>
>>> When I start apache witch loading axis module, then I get:
>>>
>>> [Mon Oct 10 09:58:16 2005] [notice] Digest: generating secret for 
>>> digest
>>> authentication ...
>>> [Mon Oct 10 09:58:16 2005] [notice] Digest: done
>>> [Mon Oct 10 09:58:16 2005] [notice] Apache configured -- resuming 
>>> normal
>>> operations
>>> [Mon Oct 10 09:58:16 2005] [notice] child pid 10191 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:16 2005] [notice] child pid 10192 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:16 2005] [notice] child pid 10193 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:16 2005] [notice] child pid 10194 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:16 2005] [notice] child pid 10195 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:17 2005] [notice] child pid 10196 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:18 2005] [notice] child pid 10197 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:18 2005] [notice] child pid 10198 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:19 2005] [notice] child pid 10199 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:19 2005] [notice] child pid 10200 exit signal 
>>> Aborted  (6)
>>> [Mon Oct 10 09:58:19 2005] [notice] child pid 10201 exit signal 
>>> Aborted  (6)
>>>
>>> end so on...
>>>
>>> I am using Gentoo Linux (x86) and Apache2 , and bin version of axis  
>>> library
>>> (I did not compile it). All other libraries (necessary for axis) 
>>> seem to
>>> be installed,
>>> but maybe I am wrong?
>>
>>
>> bin distro is compild with Xerces 2.2.
>> May be you have a different version of Xerces.
>>
>> Samisa...
>
>
> Xerces version is 2.2 ...
>
> I rebuilt axis-c and I still can not run apache with axis module.
> I tried to run on apache and apache2 - both failed.
> Both apaches are compiled with enable-so option.

Well this is really confusing to me, so many users have issues getting 
this up and running.

Please try with simple axis server. Can you run simple axis server? If 
you cant, revisit the axiscpp.conf file entries and ensure the files 
mentioned in the conf file are really there. If simple server runs 
correctly, then it is an issue with apache module. The most common 
problem I have seen is that the apache process not being able to locate 
Xerces libs.

If the problem persists, please rebuild the source with debug enabled 
(please see ant build guide) and run with gdb

Thanks,
Samisa...

>
>
>>> Thanks,
>>> Pawel
>>>
>>
>>
>
>
>


Mime
View raw message