axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Kipper <mkip...@rogers.com>
Subject Re: Need Help Installing axis-c for Linux
Date Fri, 07 Oct 2005 02:56:50 GMT

--- Samisa Abeysinghe <samisa.abeysinghe@gmail.com> wrote:

> Does this happen when you run apache alone without Axis C++? (I mean 
> without the axis entry in httpd.conf?)

Without the LoadModule entry in httpd.conf, httpd runs with no errors in
the log. Previously, it wouldn't even serve up http://localhost/, but now
it does, but the browser sits there trying to access http://localhost/axis/
 
> Looking at the error it looks to me that this is something to do with 
> C++ libs, hence this cannot be a apache problem, but a problem with 
> modules in apache.

Is it a problem with the way I compiled axis-c?
I've tried 1.5.0 and CVS, and get the same error.
I've also rebuilt xerces-c and apache, with no results.

> May be you could debug httpd with gdb and run it with -X argument inside 
> gdb, this will help you to trace the location of the error.

I've never done this before.
I've done this:

[root@lfs ~/blfs]# gdb
GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
(gdb) attach 17605
Attaching to process 17605
<snip>
Reading symbols from /opt/apache/modules/libaxiscpp_mod2.so...done.
Loaded symbols for /opt/apache/modules/libaxiscpp_mod2.so
Reading symbols from /opt/apache/modules/libaxis_server.so...done.
Loaded symbols for /opt/apache/modules/libaxis_server.so
Reading symbols from /usr/lib64/libstdc++.so.6...done.
Loaded symbols for /usr/lib64/libstdc++.so.6
Reading symbols from /usr/lib64/libgcc_s.so.1...done.
Loaded symbols for /usr/lib64/libgcc_s.so.1
0x00002aaaabc69f65 in __select_nocancel () from /lib64/libc.so.6

And now what?

Thanks,
Michael


Mime
View raw message