axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <samisa.abeysin...@gmail.com>
Subject Re: Apache says 404 on calling http://localhost/axis, all libraries found, simple_axis_server and base do work
Date Mon, 12 Sep 2005 08:47:09 GMT
On 9/12/05, Hanno Fietz <hanno@theuprightape.net> wrote:
>  Samisa,
>  
>  thank you very much for your reply.
>  
>  Samisa Abeysinghe wrote: 
>  Did you have a look into httpd's error log? Sometimes it may tell you
> why it is giving you the 404 message.
> Also, the welsome page is at http://localhost/axis/ (note the trailing '/')
>  
>  Apache log just gives me "No such file or directory", as if it was ignoring
> the "SetHandler" directive for "<Location /axis>". However, it isn't
> ignoring it: when I replace "SetHandler axis" with "SetHandler
> server-status", I get the Apache status page for http://localhost/axis. If I
> put in "SetHandler no-such-handler", I get the same result as with "axis".
>  
>  I tried the URL with and without the trailing "/". Also, the "base" program
> in $AXISCPP_DEPLOY/bin probably uses the correct path and it, too, gets a
> 404 error ("HttpTransport exception: HttpNotFound").
>  
>  I am rather sure I can rule out the following: Apache malfunction, lib
> paths not found, wrong URL. Can you think of any other possible
> configuration error etc? The Apache setup has a different path layout than
> most standard installations, modules are in /usr/lib/apache, configuration
> is in /etc/apache etc, rather than having everything in /usr/local/apache.
> Do you think that could influence Axis? As mentioned before, when I do an
> strace of Apache and its child processes, it seems as if all files can be
> found and are successfully opened and read from.
>  
>  To have the logging going, please try enable trace.
>  
>  Which logging are you referring to? How do I "enable trace"?

I am referring to Axis C++ logging.
Please see http://ws.apache.org/axis/cpp/antbuild-guide.html on how to
enable while building.

>  
>  
>  I have no idea as to how to get more information on what isn't working.
> Downgrading to 1.4.0 did not solve the issue.
>  
>  I would propose that you use latest code from cvs, or a nightly build
> because 1.4 has many bugs that are resolved by now.
>  I just downgraded to 1.4.0 temporarily, to see if it would make a
> difference. Meanwhile, I'm back on 1.5.0 (the main binary distribution).
>  
>  Do you think it might help to build Axis myself?

Yes I hope so.

Thanks,
Samisa...

> 
>  
>  Thanks
>  Hanno
>  -- 
> ------------------------------------------------------------
>  "A fly can't bird but a bird can fly
>  Ask me a riddle and I will reply:
>  Cottleston, Cottleston, Cottleston Pie"
>  - A Great Western Taoist -
> 
>

Mime
View raw message