axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <samisa.abeysin...@gmail.com>
Subject Re: axisclient crashes when deleting the Call object
Date Thu, 01 Sep 2005 10:11:57 GMT
On 9/1/05, Anders Eriksson <a.eriksson@global-imaging.net> wrote:
> 
> Hi Samisa,
> 
> Thanks for you fast reply.
> 
> I got yesterdays version from the cvs and put it in my
> application structure (source code). However, it seems
> like I have some problems calling functions in
> HTTPtransport. For example setProtocol and when setting the the
> URI nothing happens. I've seen that the HTTPTransport.dll was
> reasently modified and I got the last version but the
> problems remain.

Hmm. This is strange. Please double check the entries in axiscpp.conf
file. Also make sure that the HTTP Channel DLL is also in place.
We had the tests passing OK even this morning, so hard to believe that
there is something wrong with the code.

Anyway, please try to clean (ant clean) and build again.

> 
> just to make sure Im getting the right stuff, I got the source
> from here:
> :pserver:anoncvs@cvs.apache.org:/home/cvspublic checkout ws-axis

This should be correct. Even though we have moved to svn from last
week on, anonymous cvs checkout would give you access to the latest
code from CVS AFAIK.

Thanks,
Samisa...


> 
> Regards
> Anders
> 
> -----Message d'origine-----
> De : Samisa Abeysinghe [mailto:samisa.abeysinghe@gmail.com]
> Envoyé : mercredi 31 août 2005 15:31
> À : Apache AXIS C User List; anders@black-sand.net
> Objet : Re: axisclient crashes when deleting the Call object
> 
> 
> Hi Anders,
>     I am using the latest cvs version on Win XP and I do not get to
> see such a problem.
> 
>     Any  chance that you could try with the nigtly build?
> Thanks,
> Samisa...
> 
> On 8/31/05, Anders Eriksson <anderserikss0n@hotmail.com> wrote:
> > Hi everybody,
> >
> > I have a web services client using Axis C++ 1.5 on windows platforms.
> > The server that I am calling (upon which I have no powers) is using
> > rcp. I have done test and made changes to get my client to work
> > given this setup.
> >
> > I have made the tests on several machines (1 xp, 1 2000 and 1 2000
> > server), all with VS 6.0 install. Now, when I install my client on a
> > XP without VS 6.0 my application start to crash. It does so when
> > deleting the Call oject in AxisClient.dll. I have found out on which lines
> > it crashes and tried (for testing, well aware of the memory leak it
> creates)
> > to comment these lines (strictly delete calls, no prgram logic). The
> client
> > seems to get a bit more stable but always finnishes by crashing.
> >
> > Well, my guess is that it has to do with the dll:s that VS 6.0 change in
> > the system dll folder.
> >
> > Does anybody recognise this problem? Some help would be much
> > appreciated!
> >
> > Regards/
> > Anders
> >
> > _________________________________________________________________
> > Hitta sommarflörten på MSN! http://www.msn.se/dejting/default.asp
> >
> >
>

Mime
View raw message