axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Preston <PREST...@uk.ibm.com>
Subject RE: Trying to run simple Calculator sample client program
Date Tue, 13 Sep 2005 09:15:20 GMT
Hi Kon Kam King,
        Chinthana C. Dinapala's note yesterday "RE: Most of the test are 
failing", says that he as tested with xerces-c2_6 as well as xerces-c2_2_0 
("I have tested and its working fine for us. Both with xerces-c2_2_0 and 
xerces-c2_6 it?s working fine.").  If you cannot successfully download 
2_2_0 it would be worth trying to use 2_6.  I also note that you are 
building using MSVC 7.  All of our builds are currently built using MSVC 6 
and there are some problems that we are uncovering/investigating between 
mixing 6 and 7.  Some produce compiler warnings (as you have discovered) 
and other areas produce errors.  For the moment, ignore the warnings as it 
seems to be resolving them correctly.  The AxisClient_D.dll is the debug 
version of the AxisClient.dll (this is also true of transport and channel 
dlls).  Check the link options in your application build to make sure that 
you have specified AxisClient.lib rather than AxisClient_D.lib.  If you 
have specified '_D', it will look for AxisClient_D.dll.

Regards,

Fred Preston.





"Kon Kam King, France" <fking@cincom.com>
09/12/2005 12:08 PM
Please respond to "Apache AXIS C User List"
 
        To:     "Apache AXIS C User List" <axis-c-user@ws.apache.org>
        cc: 
        Subject:        RE: Trying to run simple Calculator sample client 
program

 

Hi,
Thanks for your help.
 I  downloaded again with your link. But I still have a problem with 
Winzip  complaining it cannot open the file it?s an invalid archive.
I also have a bubble when I point to the file saying bad zip file or  it 
may be  part of  a spanned zip file.
I am looking at my build under Microsoft Visual C++.
I see the following warnings (C4251) at compile. Can they be source of 
errors at run time?
: Calculator.cpp 
c:\axis-c-1.5\axis-c-1-5-win32\include\axis\client\Call.hpp(484) : warning 
C4251: 'axiscpp::Call::m_strProxyHost' : class 
'std::basic_string<_Elem,_Traits,_Ax>' needs to have dll-interface to be 
used by clients of class 'axiscpp::Call' with [ _Elem=char, 
_Traits=std::char_traits, _Ax=std::allocator ] 
c:\axis-c-1.5\axis-c-1-5-win32\include\axis\client\Stub.hpp(698) : warning 
C4251: 'axiscpp::Stub::m_viCurrentSOAPHeaderBlock' : class 
'std::vector<_Ty>::iterator' needs to have dll-interface to be used by 
clients of class 'axiscpp::Stub' with [ _Ty=axiscpp::IHeaderBlock * ] 
c:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\include\vector(200) 
: see declaration of 'std::vector<_Ty>::iterator' with [ 
_Ty=axiscpp::IHeaderBlock * ] 
c:\axis-c-1.5\axis-c-1-5-win32\include\axis\client\Stub.hpp(713) : warning 
C4251: 'axiscpp::Stub::m_viCurrentSOAPMethodAttribute' : class 
'std::vector<_Ty>::iterator' needs to have dll-interface to be used by 
clients of class 'axiscpp::Stub' with [ _Ty=axiscpp::IAttribute * ] 
c:\Program Files\Microsoft Visual Studio .NET 2003\Vc7\include\vector(200) 
: see declaration of 'std::vector<_Ty>::iterator' with [ 
_Ty=axiscpp::IAttribute * ] 
c:\axis-c-1.5\axis-c-1-5-win32\include\axis\AxisException.hpp(176) : 
warning C4275: non dll-interface class 'exception' used as base for 
dll-interface class 'axiscpp::AxisException' c:\Program Files\Microsoft 
Visual Studio .NET 2003\Vc7\include\exception(39) : see declaration of 
'exception'
 
Also on one link it  seemed looks for Axis_Client_D;dll, which I don?t 
find in the extract/bin.
Can these be causing the error?
 
Thanks,
France
 
 

From: Fred Preston [mailto:PRESTONF@uk.ibm.com] 
Sent: Monday, September 12, 2005 12:35 PM
To: Apache AXIS C User List
Subject: RE: Trying to run simple Calculator sample client program
 

Hi Kon Kam King, 
        I have just downloaded xerces_2_2_0 from 
http://archive.apache.org/dist/xml/xerces-c/Xerces-C_2_2_0/ (incidentally, 
http://archive.apache.org/dist/xml/xerces-c/ contains all of the builds 
from the original 1_0_0 !). 

Regards,

Fred Preston.



 
"Kon Kam King, France" <fking@cincom.com> 
09/09/2005 04:42 PM 
Please respond to "Apache AXIS C User List" 
        
        To:        "Apache AXIS C User List" <axis-c-user@ws.apache.org> 
        cc:         
        Subject:        RE: Trying to run simple Calculator sample client 
program 

 


Fred, 
Thanks for your answer. 
I am having trouble opening the xerces-c_2_2_0  from the archive site. 
Could you please send me a copy of xerces-c_2_2_0.dll 
Thanks, 
France 
  
 


From: Fred Preston [mailto:PRESTONF@uk.ibm.com] 
Sent: Friday, September 09, 2005 3:14 PM
To: Apache AXIS C User List
Subject: RE: Trying to run simple Calculator sample client program 
  

Hi Kon Kam King, 
       All of the DLLs (LIBs for Linux & AIX) must be on the path.  Don't 
forget that XERCES also needs to be on the path as does OpenSSL (if you 
are using SSL).   Reference to the 'parser library' means that it can't 
find xerces.  Be sure that you have the correct version of xerces and it 
is on the PATH environment variable (all this information should either be 
in the documentation or web site (i.e for xerces, I use 
xerces-c_2_2_0.dll). 

Regards,

Fred Preston.

 
"Kon Kam King, France" <fking@cincom.com> 
09/09/2005 10:49 
Please respond to "Apache AXIS C User List" 
        
       To:        "Apache AXIS C User List" <axis-c-user@ws.apache.org> 
       cc:         
       Subject:        RE: Trying to run simple Calculator sample client 
program 

 



When I run outside of debugger, I get the error: DLOPEN failed in
loading parser library.
The procedure being executed is :
Calculator::Calculator(const char* pchEndpointUri, AXIS_PROTOCOL_TYPE
eProtocol)
:Stub(pchEndpointUri, eProtocol)
{
}

Is the parser Xerces lib missing or in error? How do I check that?
Can somebody help?
Thanks
-----Original Message-----
From: Kon Kam King, France 
Sent: Monday, September 05, 2005 4:15 PM
To: 'Apache AXIS C User List'
Subject: Trying to run simple Calculator sample client program

I have built the Calculator sample with Vc++ with Axis-C 1.5.
I run the client under the debugger, and I get the following 
At execution of line 79                 Calculator ws (endpoint):

'Calculator_D.exe': Loaded
'C:\axis-c-1.5\axis-c-1-5-win32\bin\Calculator_D.exe', Symbols loaded.
'Calculator_D.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols
loaded.
'Calculator_D.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No
symbols loaded.
'Calculator_D.exe': Loaded
'C:\axis-c-1.5\axis-c-1-5-win32\bin\AxisClient.dll', No symbols loaded.
'Calculator_D.exe': Loaded 'C:\WINDOWS\system32\msvcp60.dll', No symbols
loaded.
'Calculator_D.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols
loaded.
HEAP[Calculator_D.exe]: Invalid Address specified to RtlFreeHeap(
00310000, 10080F0C )
Unhandled exception at 0x7c822583 in Calculator_D.exe: User breakpoint.
First-chance exception at 0x77e55dea in Calculator_D.exe: Microsoft C++
exception: axiscpp::AxisEngineException @ 0x0012f8b4.
First-chance exception at 0x77e55dea in Calculator_D.exe: Microsoft C++
exception: [rethrow] @ 0x00000000.
The program '[5144] Calculator_D.exe: Native' has exited with code 0
(0x0).

What's wrong or missing?
Thanks,
France 

Mime
View raw message