axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hawkins <HAWKI...@uk.ibm.com>
Subject RE: axis 1.5 deplloyment error. Tomcat stops immediately after start.
Date Fri, 02 Sep 2005 14:14:56 GMT
I think you need the 2-20 xerces - but you can make sure by using the 
dumpbin - it comes with XP don't know about 2003 though. It might be 
called something else?





"Kon Kam King, France" <fking@cincom.com> 
02/09/2005 14:52
Please respond to
"Apache AXIS C User List"


To
"Apache AXIS C User List" <axis-c-user@ws.apache.org>
cc

Subject
RE: axis 1.5 deplloyment error. Tomcat stops immediately after start.






Hi,
 
Here is the list od dlls I have in my simpleaxisserver\lib
AxisServer.dll          HTTPChannel.dll        AxisXMLParser.dll 
HTTPTransport.dll       xerces-c_2_6.dll
 
I tried also with xerces-c_2_2_0.dll in the lib, with the same error.
I point to the above directory in my PATH variable.
Where is the ?dumpbin ? command?
 
 

From: John Hawkins [mailto:HAWKINSJ@uk.ibm.com] 
Sent: Friday, September 02, 2005 3:32 PM
To: Apache AXIS C User List
Subject: RE: axis 1.5 deplloyment error. Tomcat stops immediately after 
start.
 

Hi, 

OK, it's good that you are seeing this on simple axis server - that makes 
the problem easier to solve :-) 

Given that you do not have an axiscpp conf file - are you ensuring that 
you have all the axis server dll's on your path? Are you also sure that 
you have the correct version of xerces. if you do "dumpbin /dependents" on 
the axis xml parser library does it show the same name as the xerces lib 
you just put in your path? 



"Kon Kam King, France" <fking@cincom.com> 
02/09/2005 14:12 


Please respond to
"Apache AXIS C User List"



To
"Apache AXIS C User List" <axis-c-user@ws.apache.org>, 
<samisa.abeysinghe@gmail.comi> 
cc
 
Subject
RE: axis 1.5 deplloyment error. Tomcat stops immediately after start.
 


 
 




Back to Axis-C.
I'm still having the exception, in spite of following the installation
instructions to the letter.
I added tne Xerces parser dll in the PATH variable with no change.
I tried installing the Simple axis Server, and it hit exactly the same
exception (instruction 0x77bd8790 referenced memory at "0x00000000".The
memory could not be read).

C:\Simple_Axis_Server>simpleaxisserver 80
Warning - The configuration file was not found
(c:\simple_axis_server\axis/axisc
pp.conf).
Using default values

Which dll is missing? Or is my windows broken?

Thanks
France
-----Original Message-----
From: Samisa Abeysinghe [mailto:samisa.abeysinghe@gmail.com] 
Sent: Tuesday, August 02, 2005 12:14 PM
To: Kon Kam King, France
Subject: Re: axis 1.5 deplloyment error. Tomcat stops immediately after
start.

> I am sorry, I mentioned Tomcat when I was meaning Apache.

Sure no problem.

By the way, you have mentioned that you did not include the directives
in the httpd.conf file. Could you please try whith those in place.

Also ensure that the Xerces parser dll is on your PATH variable.

Thanks,
Samisa...

On 8/2/05, Kon Kam King, France <fking@cincom.com> wrote:

> I have tried doing the install several times, but always hit this
error.
> 
> -----Original Message-----
> From: Samisa Abeysinghe [mailto:samisa.abeysinghe@gmail.com]
> Sent: Tuesday, August 02, 2005 1:18 AM
> To: Apache AXIS C User List
> Subject: Re: axis 1.5 deplloyment error. Tomcat stops immediately
after
> start.
> 
> Axis C++ does not have a Tomcat module, rather only an Apache modele.
> You have to add the LoadModule directive to the httpd.conf file and
> also copy the module to the location mentioned in the doc.
> 
> I have tried Axis C++ on Windows Server 2003 and it worked fine.
> 
> Thanks,
> Samisa...
> 
> On 8/1/05, Kon Kam King, France <fking@cincom.com> wrote:
> >
> >
> >
> > I am trying to instal Axis-C 1.5 with Tomcat 2.0.54 with  Xerces-C
> 2.2.2.0
> >
> > I am using Windows Server 2003.
> >
> > I followed the instructions in the Windowsi nstallation guide.
> >
> > Tomcat starts fine without adding the LoadModule directive in
> httpd.conf.
> >
> > With this directive added I hit the following error at Tomcat start
:
> >
> > The instruction at 0x77bd8790 referenced memory at 0x00000000. The
> memory
> > could not be read.
> >
> >
> >
> > Ox77bd8790 seems to be >        msvcrt.dll!77bd8790()      .
> >
> >
> >
> > The stack is>    msvcrt.dll!77bd8790()
> >
> >             msvcp60.dll!780cff53()
> >
> >             msvcp60.dll!780d49fb()
> >
> >             AxisServer.dll!0067b709()
> >
> >             AxisServer.dll!00671322()
> >
> >             AxisServer.dll!0069456d()
> >
> >             AxisServer.dll!0064fbca()
> >
> >             libapr.dll!6eed08ce()
> >
> >             mod_axis2.dll!1000196e()
> >
> >             libhttpd.dll!6ff01495()
> >
> >
> >
> > I sometimes have the following in the apache log:
> >
> > This application has requested the Runtime to terminate it in an
> unusual
> > way.
> >
> > Please contact the application's support team for more information.
> >
> >
> >
> > I have seen several posts on the subject without a clear solution.
> >
> > I have renamed the conf files, and the xerces-c_2.2_0.dll is
present.
> >
> >
> >
> > Can somebody help?
> >
> > Thanks
>

Mime
View raw message