axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yampolsky, Robert" <ryamp...@harris.com>
Subject RE: viewing wsdls in browser
Date Wed, 14 Sep 2005 18:57:37 GMT
I had this problem, and it turned out that I had set AXISCPP_DEPLOY in
my httpd init script, but had forgotten to export it.  The code that
looks for the wsdl files doesn't check for errors when it gets
AXISCPP_DEPLOY and so segfaults.
 
I also had problems with axis not setting the correct mime type for wsdl
files.  This caused Firefox to attempt to display them as HTML.  I coded
and submitted a fix for that, but I don't know if it ever got into the
mainstream distro. 
 
________________________________

From: Xavier Toth [mailto:txtoth@gmail.com] 
Sent: Wednesday, September 14, 2005 2:30 PM
To: Apache AXIS C User List
Subject: Re: viewing wsdls in browser


You meant '$AXISCPP_DEPLOY/wsdls', right? I'm running Axis C++ 1.5 on
Apache2 on Fedora Core 4.


On 9/15/05, Samisa Abeysinghe < samisa.abeysinghe@gmail.com
<mailto:samisa.abeysinghe@gmail.com> > wrote: 

	Xavier Toth wrote:
	
	> I've run the samples in apache2 but then I tried to view the
wsdls in 
	> a browser and it doesn't work. In the apache error log I see a
	> segmentation violation which I'm sure is related to the axis
c++
	> module. The axis server log contains the following:
	> [14/09/2005 11:11:33:000 CDT] 1 - > process_request 0x9d682d0 
	>
[FFFFFFD0FFFFFF82FFFFFFD6090100000015000000FFFFFF80FFFFFFF44A00]
	> <..............J.>
	> [14/09/2005 11:11:33:000 CDT] 1 AxisConfig >
getAxisConfProperty
	> @0x9c91120,[04000000] <....> 
	> [14/09/2005 11:11:33:000 CDT] 1 AxisConfig <
getAxisConfProperty
	> @0x9c91120,@1 <null>
	>
	> Has this worked for others?
	
	hmm... This is strange. It should be working, if you have the
wsdl file 
	in $AXISCPP_DEPLOY/wsdl folder.
	
	What is the version you are using? On which platform?
	
	Samisa...
	



Mime
View raw message