axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hanno Fietz <ha...@theuprightape.net>
Subject Apache says 404 on calling http://localhost/axis, all libraries found, simple_axis_server and base do work
Date Fri, 09 Sep 2005 15:15:01 GMT
I am looking for hints on the following issue:

I have installed Axis 1.5.0 with xerces 2.2.0 and Apache 2.0.48. The box
is running SuSE 9.0. The Apache installation has a path layout which is
different from that assumed in most documentations, especially the
config file layout is different. I symlinked all files in
$AXISCPP_DEPLOY/lib and $XERCESC_HOME/lib to /usr/local/lib, which is in
my LD_LIBRARY_PATH as well as in ld.so.conf.

On starting Apache, I get no errors whatsoever. No Axis log file is
created (yes - the log path named in axiscpp.conf exists and is
writeable). All paths to libraries etc seem correct. I can run
"simple_axis_server" without errors and "base" seems to be able to talk
to it OK (3 times "invoking echoString", no errors).
"run_interoptests.sh" and other scripts were not included in the
distribution (which I got from the main dist site).

Now: If I run "base" without arguments, I get an HttpNotFound exception,
the browser gives me Apache's 404 error page. All comments I could find
on the web advise me to double-check all library paths, which I did
about ten times. To be absolutely sure, I ran "strace -f -e
trace=open,read" on the Apache startup script and could see all Axis
files (libxerces and the like) being opened and read from with no
problems. There were some files that could not be opened, but apparently
(from their names and paths) they have nothing to do with Axis.

I have no idea as to how to get more information on what isn't working.
Downgrading to 1.4.0 did not solve the issue.

Any suggestions?

Thanks
Hanno

-- 
------------------------------------------------------------
"A fly can't bird but a bird can fly
  Ask me a riddle and I will reply:
  Cottleston, Cottleston, Cottleston Pie"
  - A Great Western Taoist -



Mime
View raw message