axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From csj <johns...@clarkson.edu>
Subject RE: getElementAsInt return null
Date Thu, 11 Aug 2005 11:44:50 GMT

If href/multiref is not promoted by WS-I then why is it a default setting
for Axis Java server?

On Thu, 11 Aug 2005, Samisa Abeysinghe wrote:

> Hi Chris,
>      We do not have immediate plans to fix this given that the use of
> href/multiref is not promoted by WS-I.
>
> 	However if anyone wants to fix, we would not have any
> objections.
> Thanks,
> Samisa...
>
> > -----Original Message-----
> > From: csj [mailto:johnsocs@clarkson.edu]
> > Sent: Wednesday, August 10, 2005 5:55 PM
> > To: Apache AXIS C User List
> > Subject: RE: getElementAsInt return null
> >
> > Samisa -
> >
> > Thanks, it works great.
> >
> > Also are there any plans to attack this little problem within the axis
> > team, if so when?
> >
> > ..Chris
> >
> > On Wed, 10 Aug 2005, Samisa Abeysinghe wrote:
> >
> > > The problem here is the Axis Java server is using href/muliref.
> > > Axis C++ is not able to deal with href/multiref.
> > > You could disable href/multiref on Axis Java server.
> > >
> > > Please see http://issues.apache.org/jira/browse/AXISCPP-111 for more
> > > details. This issue also mentions how to disable href/multiref in
> Axis
> > > Java.
> > >
> > > Thanks,
> > > Samisa...
> > >
> > > > -----Original Message-----
> > > > From: csj [mailto:johnsocs@clarkson.edu]
> > > > Sent: Wednesday, August 10, 2005 1:07 AM
> > > > To: axis-c-user@ws.apache.org
> > > > Subject: getElementAsInt return null
> > > >
> > > > All -
> > > >
> > > > I have a simple calculator webservice running on a Java Axis 1.2
> > > server.
> > > >
> > > > Everything works great with a Java client.  After building a C++
> > > client,
> > > > building stub code from the wsdl, my C++ Client will always seg
> fault.
> > > >
> > > > using gdb I found that
> > > > Ret = m_pCall->getElementAsInt("result", 0 );
> > > > always returns null for the following xml that the server returns.
> > > >
> > > > Any help on this would be great.
> > > >
> > > > Thanks.
> > > > Chris
> > > >
> > > > --- XML From Server ----
> > > >
> > > > <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
> > > > xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
> > > > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> > > > xmlns:xsi="http://www.w3.org/2001/XMLSchema-
> > > > instance"><soapenv:Body><ns1:addResponse
> > > > soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> > > > xmlns:ns1="http://Math.dolphtech.com"><result
> > > > href="#id0"/></ns1:addResponse><multiRef id="id0" soapenc:root="0"
> > > > soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> > > > xsi:type="xsd:int"
> > > >
> > >
> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">6</multiRef></
> > > so
> > > > apenv:Body></soapenv:Envelope>
> > >
>

Mime
View raw message