axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Eriksson <a.eriks...@global-imaging.net>
Subject RE: Settings for Java Webservice (used by C++-Client)
Date Thu, 02 Jun 2005 15:35:03 GMT

Hi Falk,

I have an Axis C++ client/Axis Java server using 
rpc. 

Corrected the following three things:

1) disable href/multiref on the server
2) slightly changing some code in AxisClient.dll
   SoapDeSerializer.cpp::getXSDType to allow 
   soapenc:string
3) making sure the server doesn't return empty
   arrays (as AxisClient can't deserialize those)

Well, not very beautiful but it works.

/Anders

-----Message d'origine-----
De : Falk Sippach [mailto:f.sippach@iez.com]
Envoyé : jeudi 2 juin 2005 17:16
À : Apache AXIS C User List
Objet : Re: Settings for Java Webservice (used by C++-Client)


Hello,

I need some more help. Is there anybody who has successfully developed
an Axis C++ client calling a Java Webservice? At the moment it's not
working at all. Are there other products (C++), which work together with
Java Axis webservices?

I've read somewhere I should use doc/lit as message style. I've tried.
First I've generated a wsdl-file with java2wsdl. Then I've created the
server skeletons (wsdl2java) and the client stubs (wsdl2ws). But wsdl2ws
fails with a not reproducable error:

--------------------
java.util.NoSuchElementException
        at java.util.HashMap$HashIterator.nextEntry(Unknown Source)
        at java.util.HashMap$ValueIterator.next(Unknown Source)
        at
org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.addDocumentStyleInputMessageToMe
thodInfo(Unknown Source)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.setMethodInfo(Unknown
Source)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.getServiceInfo(Unknown
Source)
        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.generateWrappers(Unknown
Source)

        at org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.main(Unknown Source)

Code generation failed. Please see errors above.
--------------------

If I use rpc/lit, the stub code generation succeeds. But the soap
messages look like this:

--------------------
<getStringResponse>
	<getStringReturn>test string</getStringReturn>
</getStringResponse>
--------------------

There is no type definition and the client can't read any string.


It works, if I use rpc/encoded. But then I have the problem with URI_XSD
and URI_ENC (ok, I can fix it with the patch). And I can't get int
values or complex types with ints inside. It still doesn't work in the
1.6 alpha from June 1st, 3 a. m. Maybe in the next nightly build it will
work, because Adrian has changed it yesterday (after the last nightly
build?).

What may I do wrong? Please help.

Thanks,
Falk.

Mime
View raw message