axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fred Preston <PREST...@uk.ibm.com>
Subject Fw: Axis C++ SSL problem
Date Tue, 24 May 2005 12:36:27 GMT
Hi Popa,
        I don't know if this message got through...

Regards,

Fred Preston.


----- Forwarded by Fred Preston/UK/IBM on 05/24/2005 01:33 PM -----


Fred Preston
05/24/2005 10:55 AM
 
        To:     axis-c-user@ws.apache.org
        cc: 
        From:   Fred Preston/UK/IBM@IBMGB
        Subject:        Axis C++ SSL problem

 

Hi Popa,
        There could be several reasons why SSL is not working for you... 
The SSL channel library is only loaded when it is declared in the 
axiscpp.conf file.  Check that your axiscpp.conf file contains the 
following line:-

Channel_HTTP_SSL:<inst_dir>\bin\HTTPGSKitChannel.dll

When <inst_dir> is the directory where you have installed Axis.

You do not mention what type of exception is caught by your application. 
You should have a try...catch block around the web services code.  Here is 
an example of the type of exception handling you should be using...

try
{
        WebService      ws( pszEndpoint);

        cout << "WebService test returns " << ws.test( 0) << endl;
}
catch( SoapFaultException& sfe)
{
        // Catch any SOAP fault
        cout << "SoapFaultException: " << sfe.getFaultCode() << " " <<

sfe.what() << endl;
}
catch( AxisException& e)
{
        // Catch an AXIS exception
cout << "AxisException: " << e.getExceptionCode() << " " << e.what()
<< 
endl;
}
catch( exception& e)
{
        // Catch a general exception
cout << "Unknown Exception: " << e.what() << endl;
}
catch( ...)
{
        // Catch any other exception
cout << "Unspecified Exception: " << endl;
}

Try these first and see how you get on...  It could be the problem lies 
elsewhere, but any exception thrown will help to narrow the search area 
:-)

Regards,

Fred Preston.

>is anyone there who can give me a clue.... Please ....
>
>  _____ 
>
>From: Popa Horia [mailto:horia.doru.popa@gmail.com] 
>Sent: 23 mai 2005 10:37
>To: 'axis-c-user@ws.apache.org'
>Subject: RE: Axis C++ SSL problem
>
>
>I have to mention that i have user Axis 1.5 and Axis 1.6 20 May nightly
>build ....
>
>  _____ 
>
>From: Popa Horia [mailto:horia.doru.popa@gmail.com] 
>Sent: 21 mai 2005 10:09
>To: 'axis-c-user@ws.apache.org'
>Subject: Axis C++ SSL problem
>
>
> 
>        Hi there,
> 
> 
>        I have a Java Axis server and i'm trying to connect with a stub
>written in  C++. It works fine on http but it failes on https.
>I see when I run the program in debug mode that the HttpSSLChannel is 
never
>loaded. The application failes at this line in the Stub: if (AXIS_SUCCESS 
!=
>m_pCall->initialize(CPP_DOC_PROVIDER)) return pReturn;
>        My Tomcat server is behind Apache 1.3.1 and i'm using MOD_JK to 
make
>those applications talk to each other. My guess is that the request never
>leaves my client. To prove this I have used a network sniffer and indeed,
>the client dies before any request is sent to the server. Maybe I don't 
have
>all the DDLs ?? I have installed openssl ....
>        The client runs on Windows.
> 
> 
>        Any help is appeciated.
> 
> 
>        thanks
> 
> 
> 
> 
>
>
>
>AEROSPACE√£??INFORMATION√£??CO., LTD.
> virus-free and secure email 
>
Mime
View raw message