axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yampolsky, Robert" <>
Subject RE: Can't build 1.5 source - .deps not there
Date Wed, 25 May 2005 14:17:43 GMT
Haven't tried ant.  I did install Java on this machine (to run wsdl2ws),
but have never played with ant (or Java for that matter).
Anyway, editing (painfully) all the .deps stuff allowed it to build with
make on my system.  The only component I installed was the apache2
module, and that linked and worked.
I guess if I have problems in the future, I'll try to figure out how to
use ant.


From: Samisa Abeysinghe [] 
Sent: Tuesday, May 24, 2005 10:52 PM
To: Apache AXIS C User List
Subject: RE: Can't build 1.5 source - .deps not there

Please note that the files are not up-to-date in 1.5
release. (May be it builds half way, but may not link all the stuff
correctly )
Only the ant build works properly.
Have you tried building with ant?
-----Original Message-----
From: Yampolsky, Robert [] 
Sent: Tuesday, May 24, 2005 11:44 PM
To: Yampolsky, Robert;
Subject: RE: Can't build 1.5 source - .deps not there
So, looking at the Makefile's I guess these .deps directories are
supposed to be generated on the fly by make running the 'depcomp'
I'm running RHEL 3.0, but somebody here patched the system to load the
2.96 gcc toolset as required by Oracle 9 for its installation.  I undid
the symlinks between gcc->gcc295 and g++->g++296 to point them to the
gcc323 and g++323 versions, but I'm guessing that depcomp is using other
parts of the toolchain that are inconsisten, missing or whatever.
I've been able to get the makefiles to run by editing out all the DEPS
stuff, and I suppose that's alright, since I assume this is just for
automatic dependency detection.
So, bottom line, my question is this: 
Am I looking for trouble getting Axis C++ to run on an RHEL 3.0 system
that has this hybrid compiler set? 
Is it possible that other problems I've been having (can't get ?wsdl
URL's to work) could be related to this? 
From:   Yampolsky, Robert  
Sent:   Monday, May 23, 2005 12:02 PM 
To:     '' 
Subject:        Can't build 1.5 source - .deps not there 
I'm trying to build axisc++ from the 1.5.0 source. 
Configure ran okay, but make reports failed attempts to access stuff in
.deps subdirectories.  They're not there.  Is the source tarball bad, or
is there something I can do at .configure time to make it not try to
access these .deps subdirs?
R o b   Y a m p o l s k y 
Harris Corporation 
(212) 303 - 4250 

View raw message