axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From krishna <kris...@lac.uic.edu>
Subject library http channel
Date Fri, 18 Mar 2005 03:02:23 GMT
Hi

Can you tell me where i can find a package to install http channel 
libraries.
I dont seem to have it on my system.
I was under the impression that the libhttp_channel.so library was a 
part of axis 1.5.

Cheers
Krishna

> ------------------------------------------------------------------------
>
> Subject:
> Re: Google with Axis C++
> From:
> John Hawkins <hawkinsj@uk.ibm.com>
> Date:
> Wed, 16 Mar 2005 09:33:59 +0000
> To:
> "Apache AXIS C User List" <axis-c-user@ws.apache.org>
>
> To:
> "Apache AXIS C User List" <axis-c-user@ws.apache.org>
>
>
>
> Hi,
>
> What is your channel library called and where is it ?
>
> When you've found that out you can do one of two things
> Either set your libpath to include the directory containing it
> OR
> alter the axiscpp conf file so that it points correctly to the library.
>
>
>
>
> *krishna <krishna@lac.uic.edu>*
>
> 16/03/2005 02:05
> Please respond to
> "Apache AXIS C User List"
>
>
> 	
> To
> 	axis-c-user@ws.apache.org
> cc
> 	
> Subject
> 	Google with Axis C++
>
>
>
> 	
>
>
>
>
>
> Hi
>
> I am trying to use Axis 1.5 Alpha to access the Google Web Service.The
> programs exits with the following exception
> DLOPEN FAILED in loading channel library.On doing an strace I got the
> following output.
>
> > open("/usr/lib/libhttp_channel.so", O_RDONLY) = -1 ENOENT (No such
> > file or directory)
> > stat64("/usr/lib", {st_mode=S_IFDIR|0755, st_size=12288, ...}) = 0
> > munmap(0x40677000, 22733)               = 0
> > futex(0x401c64b4, FUTEX_WAKE, 2147483647) = 0
> > futex(0x402089cc, FUTEX_WAKE, 2147483647) = 0
> > munmap(0x40664000, 76820)               = 0
> > munmap(0x4034d000, 99396)               = 0
> > munmap(0x4036c000, 3111548)             = 0
> > write(1, "AXIS_FAIL-1\n", 12AXIS_FAIL-1
>
> The libhttp_channel.so file is not found in the $AXISCPP_DEPLOY/lib
> directory too.
>
> The program seems to be looking for the libhttp_channel.so in various
> directories ( I have not included the complete output here).On looking
> up the axiscpp.conf file I found.
>
> > #Channel_HTTP_SSL:Secure Transport channel in axis3 transport
> > #Channel_HTTP:Transport channel in axis3 transport
>
> The axiscpp.conf also mentions that some of this functionality has not
> been implemented.Is the program looking for a library which has not been
> implemented?
>
> Regards
> Krishna
> http://uic.edu/~krajag2
>
>
>
>
>
>


Mime
View raw message