axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hambilton <john.hambil...@blueyonder.co.uk>
Subject Axis Client Stubs running within Component Services
Date Thu, 06 Jan 2005 12:49:35 GMT
Hello,

I've just started trying to get automatically generated C++ client
stubs running with Component Services. When I call the component I get
the following in the application event log:

The system has called a custom component and that component has failed
and generated an exception. This indicates a problem with the custom
component. Notify the developer of this component that a failure has
occurred and provide them with the information below. 
Component Prog ID: 
Server Application ID: {C65DBF8A-6099-4201-9E7E-7ED1D53DA90C}
Server Application Name: TEST
The serious nature of this error has caused the process to terminate.
Exception: E06D7363
Address: 0x7C4EA4E1
Call Stack: 
KERNEL32!RaiseException + 0x55
MSVCRT!_CxxThrowException + 0x34
AxisClient!axiscpp::Stub::s_Initialize(void) + 0xEFD9
AxisClient!initialize_module + 0x150
AxisClient!axiscpp::Call::Call(void) + 0xA2
AxisClient!axiscpp::Stub::Stub(char const *,enum AXIS_PROTOCOL_TYPE) +
0x9F
TEST!DllGetClassObject + 0x88FB
TEST!DllGetClassObject + 0x10EFA
OLEAUT32!DispCallFunc + 0x15D
OLEAUT32!ClearCustData + 0x588
TEST!DllGetClassObject + 0x18230
TEST!DllGetClassObject + 0x181A1
OLEAUT32!UserEXCEPINFO_free_local + 0x57D
 + 0xEC87CAF4

Has anybody else had any success with COM+ and Axis? Has anybody tried
it? I've had the stubs working within a COM component outside of
Component Services. I'm just trying to get an idea of how difficult
the task of running within component services is going to be.

Cheers,

John


Mime
View raw message