axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <samisa.abeysin...@gmail.com>
Subject Re: problems starting apache1.3 on linux with axis-c-1.4
Date Tue, 25 Jan 2005 09:19:21 GMT
Hi,
    According to the doc, there is no mention of AddModule.

What you have to add is:
LoadModule axis_module libexec/libaxiscpp_mod.so
 <Location /axis>
 SetHandler axis 
 </Location>
 
I am not that familiar with Apache 1.3 deployment, but I do not think
that you need "AddModule"

Please someone verify this...

Thanks,
Samisa...

On Tue, 25 Jan 2005 10:09:59 +0100, jata-c@gmx.net <jata-c@gmx.net> wrote:
> Hello Samisa,
> 
> thanks for you answer and the information.
> 
> Here is what happens:
> 
> When I remove the line "AddModule mod_axis.cpp" from the httpd.conf apache will start
but I can't acces the axis start page ("The requested URL /axis was not found on this server.")
> The error_log says:
> "[error] : Cannot remove module mod_axis.cpp: not found in module list"
> 
> If I add the AddModule line again,  apache does not start at all ("httpd could not be
started") but it doesn't give any reasons. The error_log contains no new entries and I didn't
get any other output using the -X option.
> 
> Anyway, I can't locate the file mod_axis.cpp - do I need to install it somewhere?
> 
> Thanks,
> 
> Jutta
> 
> 
> Hi,
> Please try running apache server in debug mode using:
> httpd -X
> 
> Most of the time, this will write out errors to standard output.
> 
> > (nonexistent) $AXISCPP_DEPLOY/conf ?
> $AXISCPP_DEPLOY/conf is no more used. Rather $AXISCPP_DEPLOY/etc is used.
> Make sure that axiscpp.conf is in that folder and also make sure that
> locations of the entries in the axiscpp.conf are correct.
> 
> > I already tried to install axis from sources, but there is no configure-script(?)
> Yes this is a packaging mistake. You can use the command:
> sh autogen.sh
> to generate the configure script.
> 
> Additionally have a look at the $APACHE_HOME/logs/error_log for any clues.
> If you could send more info on the httpd -X and any Axis related
> errors in $APACHE_HOME/logs/error_log, it would be easier to help fix
> the problems.
> 
> Thanks,
> Samisa...
> 
> On Mon, 24 Jan 2005 09:07:17 +0100, jata-c@gmx.net <jata-c@gmx.net> wrote:
> > Hi,
> >
> > I am using the binaries of axis-c-1.4 and followed the installation instructions
very closely. $AXISCPP_HOME and $AXISCPP_DEPLOY are known to root, and the axiscpp.conf and
server.wsdd are set up as described in the documentation.
> > But I also had to add the line "AddModule mod_axic.cpp" in the httpd.conf, otherwise
I got an errror message because of a broken config file.
> >
> > Now, when calling apachectl start, the process aborts and I get the message "httpd
could not be started". I also get a warning: ".../libaxiscpp_mod.so uses plain Apache 1.3
API, this modul might crasch under EAPI! (please recompile it with -DEAPI)".
> >
> > I already tried to install axis from sources, but there is no configure-script(?).
I am not so experienced with linux-systems, so am I missing something?
> >
> > Do I need to copy any files (axiscpp.conf) into my $APACHE_HOME directory or in
the (nonexistent) $AXISCPP_DEPLOY/conf ? I found people writing about this in some old mails,
but it seems to apply to older versions.
> >
> > Thanks for any help and regards,
> >
> > Jutta
> ______________________________________________________________
> Verschicken Sie romantische, coole und witzige Bilder per SMS!
> Jetzt bei WEB.DE FreeMail: http://f.web.de/?mc=021193
> 
>

Mime
View raw message