axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roshan Weerasuriya <ros...@opensource.lk>
Subject Re: Bug with Latest CVS
Date Thu, 06 Jan 2005 12:34:10 GMT
hi All,

When I revert back to the earlier versions of the c/src/transport/axis2
Axis2Transport.cpp Channel.cpp  Channel.h files (i.e the versions of
these files before this perticular commit) the samples started running.
So there is a problem with this change (commit) done by Samisa. Until
this problem is corrected, any one who use the CVS head source, can get
the previous versions of these 3 files and build and run your code.

Samisa, any idea about this problem?

Rgds,
Roshan

On Thu, 2005-01-06 at 18:01, Roshan Weerasuriya wrote:
> hi All,
> 
> Samisa had made a change to the Channel.cpp yesterday. 
> //-----
> samisa      2005/01/05 03:32:22
> 
>   Modified:    c/src/transport/axis2 Axis2Transport.cpp Channel.cpp
>                         Channel.h
>   Log:
>   Fixed proxy support. Tests were successful.
>   
>   Revision  Changes    Path
>   1.36      +18 -3     ws-axis/c/src/transport/axis2/Axis2Transport.cpp
> 
> Index: Channel.cpp
>   ===================================================================
>   RCS file: /home/cvs/ws-axis/c/src/transport/axis2/Channel.cpp,v
>   retrieving revision 1.11
>   retrieving revision 1.12
>   diff -u -r1.11 -r1.12
>   --- Channel.cpp       4 Jan 2005 18:26:24 -0000       1.11
>   +++ Channel.cpp       5 Jan 2005 11:32:22 -0000       1.12
>   @@ -148,18 +148,25 @@
>                 sockaddr_in                     svAddr;
>                 struct hostent *        pHostEntry = NULL;
>    
>   +                const char* host = m_URL.getHostName();
>   +                unsigned int port = m_URL.getPort();
>   +                if (m_bUseProxy)
>   +                {
>   +                    port = m_uiProxyPort;
>   +                    host = m_strProxyH
> .....
> .........
> ...........
>   
> //-----
> 
> Can this have any effect to this issue.
> 
> Roshan
> 
> On Thu, 2005-01-06 at 17:14, Roshan Weerasuriya wrote:
> > hi Rinsad and John,
> > 
> > I took a new CVS update to see whether it is a problem and I too find a
> > prblem with the latest CVS source.
> > 
> > The latest CVS source code fails, the following is the stack trace.
> >                                                                                
                                                                                         
  Channel::open() line 182
> > Axis2Transport::flushOutput() line 202 + 25 bytes
> > axiscpp::SoapSerializer::markEndOfStream() line 267 + 25 bytes
> > axiscpp::ClientAxisEngine::invoke(axiscpp::MessageData * 0x00305b70)
> > line 194
> > axiscpp::ClientAxisEngine::process(axiscpp::SOAPTransport * 0x00762e40)
> > line 115 + 20 bytes
> > axiscpp::Call::invoke(axiscpp::Call * const 0x00302fa0) line 134 + 26
> > bytes
> > Calculator::add(int 10, int 20) line 47 + 20 bytes
> >                                                                                
                                                                                         
  
> > The problem is occuring when it tries to connect. (in the Channel::open
> > () method at the following line).
> > if( connect( m_Sock, (struct sockaddr *) &svAddr, sizeof (svAddr)) ==
> > SOCKET_ERROR)
> >                                                                                
                                                                                         
  
> > Any ideas abt what went wrong , we started encountering this problem on
> > 5thJan2005 around 12.30 GMT
> > 
> > Roshan
> > 
> > 
> > On Thu, 2005-01-06 at 15:47, John Hawkins wrote:
> > > 
> > > 
> > > This message occurs when you have a problem opening the connection (as
> > it
> > > says) and the message is what it says i.e. for some reason it can't
> > open
> > > the connection to your localhost - you got a firewall? or your server
> > is
> > > down?
> > > 
> > > We've run all our tests on CVS code from about 10 hours before your
> > > checkout and ours is fine.
> > > 
> > > We'll be running our tests in about two hours so we can tell you then
> > > whether the latest code has a problem too.
> > > 
> > > 
> > > John Hawkins
> > > 
> > > 
> > > 
> > > 
> > >                                                                           

> > >              "Rinsad
> > Ahmed"                                                
> > >             
> > <rinsad@opensourc                                             
> > >             
> > e.lk>                                                      To 
> > >                                       
> > axis-c-user@ws.apache.org           
> > >              06/01/2005
> > 04:42                                           cc 
> > >                                                                           

> > >                                                                   
> > Subject 
> > >              Please respond to         Bug with Latest
> > CVS                 
> > >               "Apache AXIS
> > C                                               
> > >                 User
> > List"                                                 
> > >                                                                           

> > >                                                                           

> > >                                                                           

> > >                                                                           

> > > 
> > > 
> > > 
> > > 
> > > Hi,
> > > The latest cvs update int the morning builds fine. But when the client
> > is
> > > run,it gives a TransportException as follows
> > > 
> > > Exception : AxisTransportException:Unknown Transport Exception failed
> > to
> > > open
> > > connection to server:
> > >                                 hostname='localhost'
> > >                                 port='8080'
> > >                                 Error Message='No connection could be
> > made
> > > because the target machine actively refused it.
> > > '                               Error Code='10061'
> > > 
> > > Is there anybody who came accross same problem
> > > 
> > > Regards
> > > Rinsad
> > > 
> > > 
> > > 
> > 
> > 
> 
> 


Mime
View raw message