axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <samisa.abeysin...@gmail.com>
Subject Re: Use of xsi:type attribute.
Date Wed, 22 Dec 2004 01:22:07 GMT
Thanks for the info. Looks like it is time to look into WS-I BP, all
this time we were busy fixing more basic code level problems, and
still to some extent we do.

We have come across several problems related to XML schema, SOAP as
well as WSDL. I guess the first priority would be to make sure we know
where we are in terms of basic specs and fix problems.

Moving forward, we would have to look into BP - original plans were
for 1.5 - not sure how realistic that would be - however, we would.

Thanks,
Samisa...


On Tue, 21 Dec 2004 15:03:46 +0100, Gudbrand Hegge <g.hegge@online.no> wrote:
> Hi.
> 
> Refer to message 1068 Problem with deserialization in client (2004-11-04).
> 
> Samisa Abeysinghe wrote;
> "Looks like the missing type is causing the problem.
> I am not sure how to fix this with JBoss.
> I think it is fair enough that Axis C++ expect the type to be specified in
> SOAP."
> 
> By expecting the type to specified do this interfere with the Basic profile
> "R1017   A RECEIVER MUST NOT mandate the use of the xsi:type attribute in
> messages except as required in order to indicate a derived type".
> 
> For Basic profile 1.1 se
> http://www.ws-i.org/Profiles/BasicProfile-1.1-2004-08-24.html 3.1.8 xsi:type
> Attributes
> 
> For basic profile 1.0 see
> http://www.ws-i.org/Profiles/BasicProfile-1.0-2004-04-16.html#refinement16465616
> 
> Just curious about the differce we found in axis-c and Borland soap lib for
> delphi.
> 
> Kind regard
> Gudbrand Hegge
> 
>

Mime
View raw message