axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roshan Weerasuriya <ros...@opensource.lk>
Subject Re: Problem with Axis C++/ Win XP/ Apache 1.3.31
Date Fri, 24 Dec 2004 10:35:52 GMT
hi Mazhar,

>Here I have one doubt...I have edited the axiscpp.conf file to add the
>following lines in it. Hope I am right here.

>LogPath:C:\Program Files\Apache Group\Apache2\Axis\logs\AxisLog.txt
>WSDDFilePath:C:\Program Files\Apache
>Group\Apache2\Axis\conf\server.wsdd
>#XMLParser:AxisXMLParser.dll
>Transport_http:C:\Program Files\Apache
>Group\Apache2\Axis\lib\AxisTransport.dll
No, here you should have not comment the "XMLParser" entry. You need to
have some thing like (according to you patteren):
XMLParser:C:\Program Files\Apache
Group\Apache2\Axis\lib\AxisXMLParser.dll

Roshan

On Fri, 2004-12-24 at 16:29, Roshan Weerasuriya wrote:
> hi Mazhar,
> 
> >I tried to start the server with "apache -X" as suggested in the User
> > Manual. But theres no activity from the server. Its not coming up and
> > does not gives any error too.
> I hope you have the correct entry in the httpd.conf file.
> 
> >Also, I copied the AxisServer.dll and AxisTransport.dll in Axis\lib
> >folder.
> In addition to this you also need the Parser.dll to be copied as
> instructed in the Installation Guide. The following section is from the
> Installation guide.
> //----from the Installation guide
> 
> 10.If you want to use the Expat parser with Axis C++, rename
> AxisXMLParser_Expat.dll (which is located at Axis_Extract/bin ) to
> AxisXMLParser.dll and copy it to [Axis_Folder]/lib
> Note:The Expat XML Parser module is not currently maintained and also
> contains some bugs.For more information refer the contents section.
> 
> 11.If you want to use the Xerces parser with Axis C++, rename
> AxisXMLParser_Xerces.dll (which is located at Axis_Extract/bin ) to
> AxisXMLParser.dll and copy it to [Axis_Folder]/lib
> 
> 
>       * Copy libexpat.dll file from [Expat_Folder]\Libs to
>         [Axis_Folder]/lib/
>       * Copy xerces-c_2_2_0.dll from [Xerces_Folder]/bin/ to
>         [Axis_Folder]/lib/
> 
> //------end from the Installation guide------
> Currently Axis C++ supports only the Xerces parser. So you have to
> follow the instructions related to the Xerces parser from the above.
> Otherwise you will get problems, because you need at least one of them
> to use Axis C++.
> 
> >Here I have one doubt...I have edited the axiscpp.conf file to add the
> > following lines in it. Hope I am right here.
> > 
> > LogPath:C:\Program Files\Apache Group\Apache2\Axis\logs\AxisLog.txt
> > WSDDFilePath:C:\Program Files\Apache
> Group\Apache2\Axis\conf\server.wsdd
> > #XMLParser:AxisXMLParser.dll
> > Transport_http:C:\Program Files\Apache
> Group\Apache2\Axis\lib\AxisTransport.dll
> > 
> > Since I have not installed the XML Parser I have commented it.
> No, you need at least one of the above mentioned parsers to run Axis
> C++, because both either at the server or client side XML parsing is
> happening. So you need to follow the above step which I have mentioned.
> Also you will have to install the xerces-c parse as instructed in the
> Installation Guide.
> 
> After doing this still if you have a problem let us know, it in details
> with the error messages.
> 
> Rgds,
> Roshan
> 
> 
> On Fri, 2004-12-24 at 15:33, Mazhar wrote:
> > Hi Roshan,
> > 
> > Now I using "httpd-2.0.52-win32-x86-src" Server and "axis-c-win32-current-bin"
> > 
> > But this time the problem looks quite unsual...
> > 
> > I tried to start the server with "apache -X" as suggested in the User
> > Manual. But theres no activity from the server. Its not coming up and
> > does not gives any error too.
> > 
> > I have copied the mod_axis2.dll in the modules folder of Apache
> > Installation folder.
> > 
> > Also, I copied the AxisServer.dll and AxisTransport.dll in Axis\lib folder.
> > 
> > Added the Axis\lib to Path environment variable
> > 
> > Changed the axiscpp.conf_win to axiscpp.conf and same with server.wsdd file
> > 
> > Here I have one doubt...I have edited the axiscpp.conf file to add the
> > following lines in it. Hope I am right here.
> > 
> > LogPath:C:\Program Files\Apache Group\Apache2\Axis\logs\AxisLog.txt
> > WSDDFilePath:C:\Program Files\Apache Group\Apache2\Axis\conf\server.wsdd
> > #XMLParser:AxisXMLParser.dll
> > Transport_http:C:\Program Files\Apache Group\Apache2\Axis\lib\AxisTransport.dll
> > 
> > Since I have not installed the XML Parser I have commented it.
> > 
> > Could you suggest where I might be going wrong ?
> > 
> > Mazhar
> > 
> 
> 


Mime
View raw message