axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Day Reynolds, LennonX J" <lennonx.j.day.reyno...@intel.com>
Subject Hopefully an easy question
Date Mon, 08 Nov 2004 20:09:46 GMT
I'm working on a simple SOAP client using Axis C++ 1.3 on Windows,
consuming a .NET 1.1 hosted web service. Everything is being built in
VS.NET, and I compiled from sources, rather than using the binary
distribution, to insure debugging info was included in all the
libraries. My client code is using the WSDL2WS-generated stubs.

I've got everything going fine up to the point of an actual call, when
I'm getting an untraceable AxisTransportException somewhere in the Axis
core which I can't step through in the debugger, despite using the debug
libraries.

Tracing the HTTP transaction, I can see that the on-the-wire request and
response look fine. The exceptions come up at following point in each
auto-generated method wrapper:

if (AXIS_SUCCESS == m_pCall->invoke()) { // <-- exception thrown here
	...
}

The exception code is 38, a.k.a. "invalid string". As I said, nothing in
the actual server response seems out of place, so the this error code is
not something I expected. I can post a bit more code and/or example if
people need it; my hope is, however, that this is a simple configuration
issue that someone will have seen before. Any suggestions about where I
should be looking for the root cause of this exception?

Thanks,

Lennon Day-Reynolds
lennonx.j.day.reynolds@intel.com

Mime
View raw message