axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samisa Abeysinghe <samisa_abeysin...@yahoo.com>
Subject Update http://ws.apache.org/axis/ [WAS: RE: Win32 Exception 1.3 Beta]
Date Tue, 02 Nov 2004 01:28:44 GMT
http://ws.apache.org/axis/ wep page still says that 

NEWS (September 30, 2004) : Axis 1.2 RC1 release is now available!

NEWS (September 15, 2004) : Axis C++1.3 Beta is now available! 

No news on 1.3 Final.
Please update this web page.

Samisa...

--- Robert Sanford <rsanford@trefs.com> wrote:

> Arrrrrggggghhhhh!!!
> 
> UPDATE THE FREAKIN' WEB SITE!
> 
> I'm not on the mailing list most of the time because most of the time I
> don't care. If I was on even one mailing list for every 3rd party tool that
> I use I would get fired for taking up too much disk space. But I *do* check
> the website fairly regularly and even today there is NO mention of the fact
> that 1.3 has been released. It's been how long?
> 
> Please help the lurkers and the hangers on out. We really want to be
> productive but we don't hit CVS every day.
> 
> I'll send out an update after I've compiled and tested.
> 
> rjsjr
> 
> > -----Original Message-----
> > From: Robert Sanford [mailto:rsanford@trefs.com] 
> > Sent: Monday, November 01, 2004 2:41 PM
> > To: axis-c-user@ws.apache.org
> > Subject: Win32 Exception 1.3 Beta
> > 
> > 
> > I ONLY care about the C++ CLIENT software running on Win32.
> > 
> > I have downloaded and compiled the source for the 1.3 beta 
> > client software using the Distribution.dsw workspace for 
> > VisualC++. I am compiling on Visual Studio 6 SP 5. I am 
> > running on XP SP2. The behavior below is also duplicated on 
> > Win2K as well so it isn't the XP SP2 network blocking issue.
> > 
> > I am connecting to a Java version 1.1 server.
> > 
> > When I connect with a Java 1.1 client to the server and 
> > receive a response of > 1K I get the full set of data.
> > 
> > When I connect with the 1.3Beta C++ client software and 
> > receive a response of < 1K I get the full data set.
> > 
> > When I connect with the 1.3Beta C++ client software and 
> > receive a response of > 1K I get a transport exception.
> > 
> > Tracing into the code I *do* receive the SOAP Body element 
> > and I *do* receive my SOAP response element. But when I 
> > attempt to actually retrieve the contents of my response 
> > element and the response is > 1K I get a transport level 
> > exception thrown. I don't fully understand the code but it 
> > appears that the code has received a partial document which 
> > is sufficient to fill in the body and response element but it 
> > has not received the full document. Once it attempts to 
> > receive the full document the transport level exception is 
> > thrown. I am guessing on that so those that actually know the 
> > code should stick to their knowledge.
> > 
> > My (admittedly simplistic) code is attached.
> > 
> > Is there a configuration option that I need to set?
> > 
> > Is this an issue because of the blocking read in
> >   HttpTransport::operator >>
> > 
> > Am I missing something?
> > 
> > Thanks!
> > 
> > rjsjr
> > 
> > 
> > 
> 



		
__________________________________ 
Do you Yahoo!? 
Check out the new Yahoo! Front Page. 
www.yahoo.com 
 


Mime
View raw message