axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schröder ...@theta-soft.de>
Subject Re: Installation problems with Axis 1.2 and Apache 1.3
Date Wed, 15 Sep 2004 07:37:04 GMT
Christian Schroeder wrote:

> I have tried to install Axis C++ 1.2 (because I do not want to use an 
> alpha release, which 1.3 is) on an Apache 1.3 server, but I did not 
> manage to get it running.
> I downloaded the source archive, set all the environment variables and 
> compiled and installed everything without problems.
> Because my Apache is not installed in the usual directory (it's a SuSE 
> distribution), I could not use the "deploy_apache.sh" script, but 
> manually copied the files to the appropriate directories.
> I added the "LoadModule" and the "<Location /axis> ... </Location>" 
> lines to the Apache config file and restarted apache.
> The module seems to load (at least no error message is printed), but 
> when I try to access "/axis" I get a "404 not found" reply. The Apache 
> error log says that the directory "/axis" could not be found, so it 
> seems the handler is not invoked correctly. However, the "Location" 
> block is correctly understood. (I simply added a "Deny from all" 
> statement, and it worked.)

Ok, I think I found out some more details: In SuSE's Apache config, a 
"ClearModuleList" statement is placed after all the "LoadModule" 
statements. I thought this would not apply to shared modules, but it 
seems to do. I inserted an "AddModule mod_axis.cpp" after the 
"ClearModuleList", and now at least the handler seems to be activated. 
But now I get a segmentation fault ...
I tried to remove the "ClearModuleList" and all of the "AddModule" 
statements, but it didn't change anything.
Of course the "/usr/local/Axis/logs" directory is world writable and the 
Axis config files seem to be ok.

Any more hints?

Regards,
    Chris

Mime
View raw message