axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schröder ...@theta-soft.de>
Subject Installation problems with Axis 1.2 and Apache 1.3
Date Tue, 14 Sep 2004 18:07:44 GMT
Hi all,
I have tried to install Axis C++ 1.2 (because I do not want to use an 
alpha release, which 1.3 is) on an Apache 1.3 server, but I did not 
manage to get it running.
I downloaded the source archive, set all the environment variables and 
compiled and installed everything without problems.
Because my Apache is not installed in the usual directory (it's a SuSE 
distribution), I could not use the "deploy_apache.sh" script, but 
manually copied the files to the appropriate directories.
I added the "LoadModule" and the "<Location /axis> ... </Location>" 
lines to the Apache config file and restarted apache.
The module seems to load (at least no error message is printed), but 
when I try to access "/axis" I get a "404 not found" reply. The Apache 
error log says that the directory "/axis" could not be found, so it 
seems the handler is not invoked correctly. However, the "Location" 
block is correctly understood. (I simply added a "Deny from all" 
statement, and it worked.)

The troubleshooting guide mentions several possible reasons, but I
  - made everything below the axis directory group and world writable,
  - set (and exported) AXIS_HOME to point to the axis directory,
  - checked that axiscpp.conf is in the right directory and is readable,
  - checked all the paths in axiscpp.conf
I did not change anything inside the server.wsdd file, so I don't assume 
that it contains any errors.

Is there any other explanation what goes wrong? Where can I find some 
more information? Apache's error log does not show any errors.

Thanks for your help!

Christian

P.S.:
Output of httpd -V:
Server version: Apache/1.3.27 (Linux/SuSE)
Server built:   Jun 17 2004 12:29:07
Server's Module Magic Number: 19990320:13
Server compiled with....
 -D EAPI
 -D EAPI_MM
 -D EAPI_MM_CORE_PATH="/var/lib/httpd/mm"
 -D HAVE_MMAP
 -D HAVE_SHMGET
 -D USE_SHMGET_SCOREBOARD
 -D USE_MMAP_FILES
 -D HAVE_FCNTL_SERIALIZED_ACCEPT
 -D HAVE_SYSVSEM_SERIALIZED_ACCEPT
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D HARD_SERVER_LIMIT=2048
 -D HTTPD_ROOT="/srv/www"
 -D SUEXEC_BIN="/usr/sbin/suexec"
 -D DEFAULT_PIDLOG="/var/run/httpd.pid"
 -D DEFAULT_SCOREBOARD="/var/run/httpd.scoreboard"
 -D DEFAULT_LOCKFILE="/var/run/httpd.lock"
 -D DEFAULT_ERRORLOG="/var/log/httpd/error_log"
 -D TYPES_CONFIG_FILE="/etc/httpd/mime.types"
 -D SERVER_CONFIG_FILE="/etc/httpd/httpd.conf"
 -D ACCESS_CONFIG_FILE="/etc/httpd/access.conf"
 -D RESOURCE_CONFIG_FILE="/etc/httpd/srm.conf"


Mime
View raw message