axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Susantha Kumara" <susan...@opensource.lk>
Subject RE: Samples does not run, no deployed services available
Date Wed, 26 May 2004 08:47:05 GMT
I assure that all samples shipped with binaries work fine. Could you
check the http packet using tcpmonitor and send it to me so that I can
find what is wrong ?.

---
Susantha Kumara
Virtusa (pvt) Ltd.
Office : +94112714385
Mobile : +94777420453

> -----Original Message-----
> From: Michael Kenrich [mailto:Michael.Kenrich@pss-systems.com]
> Sent: Tuesday, May 25, 2004 10:02 PM
> To: Apache AXIS C User List
> Subject: RE: Samples does not run, no deployed services available
> 
> After struggling for a week with many of the problems reported by you
> and others here (exceptions, deserialization of responses, etc.), I
> finally punted and started using gSoap instead. This allows my C++
> application to access a web service implemented on JBoss using Axis
for
> Java. I had incorrectly assumed that Axis C++ would be the best choice
> for working with Axis Java.
> 
> My own impression is that the Axis C++ samples were not well tested in
a
> Win32 environment. I tried Apache 1.x, 2.x as well as the
> SimpleAxisServer with no good results.
> 
> Michael F. Kenrich
> 
> -----Original Message-----
> From: Scharinger, Florian [mailto:florian.scharinger@joanneum.at]
> Sent: Monday, May 24, 2004 6:27 AM
> To: axis-c-user@ws.apache.org
> Subject: Samples does not run, no deployed services available
> 
> 
> Hi there,
> 
> I already posted (an unanswered) message two weeks ago, when I had
> problems connecting to a WebService (Invoke success, CheckMessage
> fails).
> 
> Still, this does not work.
> 
> I also figured out, that the provided samples (e.g. Calculator) do NOT
> work (properly). When using the SimpleAxisServer.exe, the return
result
> of the Calculator is always the first passed parameter.
> ---
> Calculator.exe localhost 8080 add 7 5
> Sending Requests to Server http://localhost:8080 ........
> 
> Result : 7
> ---
> 
> Thus I opened the calculator client source with VS.NET, and debugged:
> 
>  Although
> int Calculator::add(int Value0, int Value1)
> {
> [...]
> 	if (AXIS_SUCCESS == m_pCall->Invoke())
> [...]
> }
> returns AXIS_SUCCESS, the method fails actually!
> 
> The problem is in clientaxisengine.cpp, method:
> int ClientAxisEngine::Process(Ax_soapstream* pSoap)
> {
> [...]
> 	pService = g_pWSDDDeployment->GetService(pchService);
> [...]
> }
> Method 'GetService' returns NULL, because the member
> 'm_DeployedServices' (wsdddeployment.cpp) is NULL.
> 
> 
> This brings me to the end: Do I have to deploy the /sample/
WebServices
> somewhere additionally (or programmatically)?
> 
> 
> I really appreciate an answer, otherwise we have to go via JNI to a
Axis
> Java Stub Client :(
> 
> 
> Florian.
> 
> 
> 
> /------------------------------------------------------------------\
>   Florian Scharinger
>   Institute of Information Systems & Information Management
>   JOANNEUM RESEARCH Forschungsgesellschaft mbH
>   Steyrergasse 17, A-8010 Graz, AUSTRIA
> 
>   phone:  +43-316-876-1219                   fax: +43-316-876-1191
>   web:    http://www.joanneum.at/iis
>   e-mail: mailto:florian.scharinger@joanneum.at
> \------------------------------------------------------------------/
> 
> 



Mime
View raw message