axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zolyomi Istvan (EXT-IT-Guru/Budapest)" <Ext-Istvan.Zoly...@nokia.com>
Subject Re: Samples fail when run severaltimes
Date Wed, 14 Apr 2004 13:35:20 GMT

Same thing happens to me when testing samples base and doclitbase. If
one is executed, the other does not work until apache is restarted:

--------------------------------------------------------------
[scam@budhcp16981 client]$ ./base
Usage :
 ./base <server> <port>

Sending Requests to Server http://localhost:80 ........

invoking echoString...
hello world hello world successful
invoking echoStringArray...
successful
invoking echoInteger...
successful
invoking echoIntegerArray...
successful
invoking echoFloat...
successful
invoking echoFloatArray...
successful
invoking echoStruct...
successful
invoking echoStructArray...
successful
invoking echoVoid...
successful
invoking echoBase64...
successful
Returned String :
some string that is sent encoded to either base64Binary or hexBinary
invoking echoDate...
successful
invoking echoHexBinary...
successful
Returned String :
some string that is sent encoded to either base64Binary or hexBinary
invoking echoDecimal...
successful
invoking echoBoolean...
successful

[scam@budhcp16981 client]$ ./doclitbase
Usage :
 ./doclitbase <server> <port>

Sending Requests to Server http://localhost:80 ........

invoking echoString...
failed
invoking echoStringArray...
failed
failed
Done
invoking echoInteger...
failed
invoking echoIntegerArray...
failed
invoking echoFloat...
failed
invoking echoFloatArray...
failed
invoking echoStruct...
failed
invoking echoStructArray...
failed
invoking echoVoid...
successful
invoking echoBase64...
failed
invoking echoDate...
failed
invoking echoHexBinary...
failed
invoking echoDecimal...
failed
invoking echoBoolean...
failed
---------------------------------------------------------

If I restart apache and run them in reverse order, the results are:

----------------------------------------------------------
[root@budhcp16981 Axis]# ../bin/apachectl restart

[scam@budhcp16981 client]$ ./doclitbase
Usage :
 ./doclitbase <server> <port>

Sending Requests to Server http://localhost:80 ........

invoking echoString...
successful
invoking echoStringArray...
successful
successful
Done
invoking echoInteger...
successful
invoking echoIntegerArray...
successful
invoking echoFloat...
successful
invoking echoFloatArray...
successful
invoking echoStruct...
successful
invoking echoStructArray...
successful
invoking echoVoid...
successful
invoking echoBase64...
successful
Returned String :
some string that is sent encoded to either base64Binary or hexBinary
invoking echoDate...
successful
invoking echoHexBinary...
successful
Returned String :
some string that is sent encoded to either base64Binary or hexBinary
invoking echoDecimal...
successful
invoking echoBoolean...
successful

[scam@budhcp16981 client]$ ./base
Usage :
 ./base <server> <port>

Sending Requests to Server http://localhost:80 ........

invoking echoString...
Segmentation fault
-------------------------------------------------------------------

It's kinda strange, we still didn't have time to debug it.

Istvan

> The problem remains. Once you build all from scratch and run the
samples for the first time all works fine. 
> But when samples are tried multiple times, they start working differently time to time.


Mime
View raw message