axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean Michel MAISONNAVE" <jeanmichel.maisonn...@cgey.com>
Subject RE: Axis/apache error
Date Thu, 25 Mar 2004 13:27:44 GMT
Hi,
Thks a lot for helping me. 

I have compiled the 2.5 version of xerces and put it in my /usr/lib

[root@FWSAM00 lib]# pwd
/usr/lib
[root@FWSAM00 lib]# ls -l|grep xerces
lrwxrwxrwx    1 root     root           49 mar 23 17:14 libxerces-c.so ->
/XML/XERCES/xerces-c-src_2_5_0/lib/libxerces-c.so
lrwxrwxrwx    1 root     root           52 mar 23 17:49 libxerces-c.so.25 ->
/XML/XERCES/xerces-c-src_2_5_0/lib/libxerces-c.so.25

Where can i configure LD_LIBRARY_PATH var?

Regds

JM



----------------------------------------
 
Jean Michel MAISONNAVE
Concepteur Réalisateur Intégrateur
Tour Europlaza - La Défense
Mail : jeanmichel.maisonnave@CapGemini.fr
Tél  : 01.49.00.44.17
---------------------------------------- 

-----Message d'origine-----
De : damitha@opensource.lk [mailto:damitha@opensource.lk] 
Envoyé : jeudi 25 mars 2004 11:09
À : Apache AXIS C User List
Objet : RE: Axis/apache error

Hi,
 Now the problem is apache cannot find the xerces libraries. Make sure that
the xerces libraries are placed so that apache can see it at load time. For
example you can put it on /usr/lib or you can put it somewhere and make
LD_LIBRARY_PATH  point to that.

regds,
damitha

> Hi
> Thks for your help
> I were using the ./configure in /apache/src Thats why it didnt work 
> with the --enable-module=so switch But now, the error is:
>
> [root@FWSAM00 support]# ./apachectl restart ./apachectl restart: httpd 
> not running, trying to start Syntax error on line 978 of 
> /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libaxiscpp_mod.so into server:
> /usr/local/apache/libexec/libaxiscpp_mod.so: undefined symbol:
> _ZTIN11xercesc_2_213XMLEntityDeclE
> ./apachectl restart: httpd could not be started
>
> Do you have an idea?
>
> ----------------------------------------
>
> Jean Michel MAISONNAVE
> Concepteur Réalisateur Intégrateur
> Tour Europlaza - La Défense
> Mail : jeanmichel.maisonnave@CapGemini.fr
> Tél  : 01.49.00.44.17
> ----------------------------------------
>
> -----Message d'origine-----
> De : damitha@opensource.lk [mailto:damitha@opensource.lk] Envoyé : 
> jeudi 25 mars 2004 10:44 À : Apache AXIS C User List Objet : Re: 
> Axis/apache error
>
> Hi,
> When you built apache did you give the configure option ./configure 
> --enable-modue=so
>
>
> damitha
>
>> hi
>> i wanted to Axis c++  on Apache Server.
>> I follow the linux install guide, but at the end, i have this error:
>>
>> [root@FWSAM00 support]# ./apachectl restart ./apachectl restart: 
>> httpd not running, trying to start Syntax error on line 978 of
>> /usr/local/apache/conf/httpd.conf:
>> Invalid command 'LoadModule', perhaps mis-spelled or defined by a 
>> module not included in the server configuration ./apachectl restart:
>> httpd could not be started
>>
>> This is the end of my httpd.conf file:
>> LoadModule axis_module libexec/libaxiscpp_mod.so <Location /axis> 
>> SetHandler axis </Location>
>>
>> The path of the libaxiscpp_mod.so is /usr/local/apache/libexec.
>>
>> What's wrong?
>>
>> Thks for your help.
>>
>> JM
>>  <mailto:axis-c-user@ws.apache.org'>
>>
>
>
>


Mime
View raw message