axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Migue Angel Olivan Monge <maoli...@tecisa74.com>
Subject RE: C++ Axis Server and .NET C# Client problem
Date Thu, 25 Mar 2004 11:39:58 GMT
Hi Andras,
I had got the same message, but using tcpmon I saw:
 
POST /axis/Calculator HTTP/1.1
VsDebuggerCausalityData: (random characters?)
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; MS Web Services Client
Protocol 1.1.4322.573)
Content-Type: text/xml; charset=utf-8
SOAPAction: ""
Content-Length: 565
[blah blah...]
 
SOAPAction is empty. I supose that VS.NET generate SOAPAction with the wsdl
file. The first parameter of the call to the remote object is "" (the name
is Action). You can change that and the service run. I supose that there is
a better way to do that (a correct wsdl?) but I don?t know, because my
knowledge from wsdl are minimum...
 
Regards,
Miguel
 
P.S. Sorry for my english :)


-----Mensaje original-----
De: Horti, Andras [mailto:andras.horti@joanneum.at]
Enviado el: martes, 23 de marzo de 2004 17:03
Para: axis-c-user@ws.apache.org
Asunto: C++ Axis Server and .NET C# Client problem


Hi All,
 
I managed successfully to deploy an Axis C++ WebService. I can connect with
an Axis C++ client, but have no chance with other tools. 
The .NET Studio complains about wrong http protocol if I try to add a web
reference by WSDL  over http://..?wsdl <http://..?wsdl>  . If I implement it
then from a file, then the application reports that the service is not
registered.
I tried to implement by JBuilder+WASP. The application throws an Exception
saying that HTTP status line error.
 
Attaced is the WSDL file.
 
Thanks
Andras


Mime
View raw message