axis-c-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mirabile, Ismael" <Ismael.Mirab...@turner.com>
Subject RE: Problems building & deploying the Axis C++
Date Fri, 30 Jan 2004 14:03:17 GMT
Thanks damitha, I know you guys are very busy and I appreciate the time you're dedicating to
this project. It really saves us a lot of time and effort putting together our solutions.


I got the latest from cvs and here is a more detailed description about the problem I'm having:


I'm using the Axis c++ in the client only. After buiding the Axis c++ server and running into
deployment issues, I decided to use the Java server instead since it seems to be more stable.

Using the client samples that come in [CHECKOUT_FOLDER]/c/vc/client/samples/interoptests/base
I modified the InteropTestPortType class to call a Calculator service that I have in the Axis
Java server. Here's the posted request taken from TCPMonitor:

POST /tgn-services/services/Calculator HTTP/1.1
Host: shadow.turner.com
Content-Type: text/xml; charset="utf-8"
SOAPAction: "Calculator#add"
Content-Length: 541

<?xml version="1.0" encoding="utf-8" ?>
<SOAP-ENV:Envelope 
SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" 
xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" 
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SOAP-ENV:Body>
<ns1:add xmlns:ns1="http://shadow.turner.com:8080/tgn-services/services/Calculator">
<a xsi:type="xsd:int">7</a>
<b xsi:type="xsd:int">7</b>
</ns1:add>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>


The service then generates this response -- again taken from TCPMonitor:


HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Transfer-Encoding: chunked
Date: Thu, 29 Jan 2004 23:14:06 GMT
Server: Apache Coyote/1.0

1f9
<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <ns1:addResponse soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns1="http://shadow.turner.com:8080/tgn-services/services/Calculator">
   <ns1:addReturn xsi:type="xsd:int">14</ns1:addReturn>
  </ns1:addResponse>
 </soapenv:Body>
</soapenv:Envelope>
0

Notice the "1f9" and the "0" in the begining and end of the envelope. This seems fine since
is the same response generated when I used a C# and Java client for test, however I don't
know for sure why the server is generating that but it looks like an Apache encoding -- this
is a guess, if someone knows for sure please correct me.

Apparently this is breaking the xml parser algorithm during the execution of the soap deserealizer
since it recognizes it as part of the body. The problems seems to be in here:

int SoapDeSerializer::GetBody()
{
if (!m_pNode) m_pNode = m_pParser->Next(); 
/* previous header searching may have left a node unidentified */

When the expected result seems to be START_ELEMENT but it does not come back as such...

Any help would be appreciated.

Thanks,
Ismael


-----Original Message-----
From: damitha@opensource.lk [mailto:damitha@opensource.lk]
Sent: Thursday, January 29, 2004 11:02 PM
To: axis-c-user@ws.apache.org
Subject: Re: Problems building & deploying the Axis C++


> Hi,
>
> I recently checked out from cvs the code for the c++ version of Axis and
> tried to build it using Visual Studio 6 and 7.


Hi Ismael,
I wonder somebody has already answered your question.
Pleae download the latest from the cvs head
cvs checkout -d <yourlocalfolder> ws-axis/c(If you already
has defined CVSROOT env varible.)
We have tested it using vc6.

If still problem exists please send me a more detailed error
description.



damitha

>
> On both cases I had several errors and warnings in the Soap and other
> modules.
>
> After correcting the errors -- some were syntax errors, I could not
> deploy the build because it prevented my Apache server from starting --
> I am using Apache 1.3.24 as recommended.
>
> I am writing this message after having tried possibly everything in the
> last couple of days to get the code working.
>
> Is it anything special that I need to do in order to use the cvs source
> as a base for my development?
>
> (As far as the binary version, I can deploy but none of the tests work.
> the "InteropBase" service shows success in some of the tests but by
> checking the packets on TCPMonitor I could see that the responses were
> actually error messages)
>
> Thank you very much.
> Ismael M.Jr.


Mime
View raw message