axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From manoj dhyani <>
Subject axis2_http_client_connect_ssl_host() HTTP Protocol Version Hardcoded to 1.0 ?
Date Wed, 06 Mar 2013 03:03:21 GMT

I am running into a issue when connecting to a HTTPS webservice via certain proxy servers
(like ASTARO) where connection is getting closed, the HTTP Protocol in Axis2.xml is set to

looking at the code, I see the following

Axis2c version 1.6.0


file - src\core\transport\http\sender\http_client.c


function - axis2_http_client_connect_ssl_host(

axis2_http_client_t * client,

const axutil_env_t * env,

axis2_char_t * host,

int port)


sprintf(connect_string, "CONNECT %s:%d HTTP/1.0\r\n\r\n", host, port);

axutil_stream_write(tmp_stream, env, connect_string,

axutil_strlen(connect_string) * sizeof(axis2_char_t));


why is this hardcoded ? is this by design or a bug ?


is there any way to keep the connection alive ? I tried passing Connection : Keep-Alive in
the header but that is not working either

I haven't tried changing the hardcoded value from 1.0 to 1.1 not sure what will be the implication

View raw message