axis-c-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nadir amra (JIRA)" <axis-c-...@ws.apache.org>
Subject [jira] Reopened: (AXISCPP-1072) AxisSoapException: Soap message content is not valid. Unexpected or extraneous element (ProductInformation) encountered.
Date Thu, 29 Jul 2010 05:15:18 GMT

     [ https://issues.apache.org/jira/browse/AXISCPP-1072?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

nadir amra reopened AXISCPP-1072:
---------------------------------


hmmm, maybe i was hasty.  need to look into this a little more. 

> AxisSoapException: Soap message content is not valid. Unexpected or extraneous element
(ProductInformation) encountered.
> ------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AXISCPP-1072
>                 URL: https://issues.apache.org/jira/browse/AXISCPP-1072
>             Project: Axis-C++
>          Issue Type: Bug
>          Components: Client - Deserialization
>    Affects Versions: current (nightly)
>         Environment: Axis Client : latest code from SVN 
> XMLParser: xerces-c-2.7.0
> WSDL2WS: Build with latest code using Axis Java 1.4
> Compiler: VC++ 2005(Vc8)
>            Reporter: Srinivas Umareddy
>             Fix For: current (nightly)
>
>         Attachments: axisclient.log, NPIDataServices.wsdl
>
>
> I have rebuild Axis c++ client code with latest code using xerces-c-2.7.0. I have generate
the my cilent code with latest wsdl2ws tool. I see checkForExtraneousElements() introduced
with latest wsdl2ws. 
> I am getting below error message when i execute the new code. Looks like some thing broken
or i am missing some thing. 
> Here is my soap responce.
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>  <soapenv:Body>
>   <ProductInfoResponse xmlns="http://www.cat.com/NPIDataServices/2007/02/05">
>    <ProductInfoResponse xmlns="">
>     <SerialNumber>B1L</SerialNumber>
>     <ProductGroup>ARTICULATED TRUCKS</ProductGroup>
>     <GenericModel>725</GenericModel>
>     <PrimaryModel>725</PrimaryModel>
>     <SerialNumberBuilt>2250</SerialNumberBuilt>
>     <LastBuild>2010-04-30 00:00:00.0</LastBuild>
>     <Facility>PETERLEE (U2)</Facility>
>     <EngineeringModel>RM715</EngineeringModel>
>     <EngineeringVersion>-</EngineeringVersion>
>     <GeneralArrangement >2268615</GeneralArrangement >
>     <AssociatedModel>RM574</AssociatedModel>
>     <ProductType>AD</ProductType>
>     <CaptiveEngineModel>C11</CaptiveEngineModel>
>     <EngineFacilityCode>40</EngineFacilityCode>
>     <EngineFamily>ZE</EngineFamily>
>     <OldNewAssociatedModel>O</OldNewAssociatedModel>
>    </ProductInfoResponse>
>   </ProductInfoResponse>
>  </soapenv:Body>
> </soapenv:Envelope>
> Looks above soap not having any extraneous element. Why my client code is not working.

> please help on this issue. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: c-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: c-dev-help@axis.apache.org


Mime
View raw message